Skip to content

Commit

Permalink
net-vpn/tor: version bump to 0.3.0.10
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
blueness committed Aug 2, 2017
1 parent 0d45c1e commit 0fcaa6e
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-vpn/tor/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST tor-0.2.9.10.tar.gz 5557586 SHA256 d611283e1fb284b5f884f8c07e7d3151016851848304f56cfdf3be2a88bd1341 SHA512 c18c4faf18406f04165136f0d70e6bc2896f3f02770beadaab5e7a99441d71b897ae3a14a046eaec99a1bd6d8ad7758b28f7d652588842b77621cdc95d4fb7e1 WHIRLPOOL 8a12ab4bd148c6cf57e4e21ae29ccff46b9f687a1646f4453b0ba312b97b78d0c2a428f3178f47e58ec012eb2edce53efff4e07d7f0418d7ccc4ded3856a84a0
DIST tor-0.3.0.10.tar.gz 5845205 SHA256 9a8e6e49a1688dae64dca10f84a414ec9a4f393fb2256ae28e0c2e3239185ab1 SHA512 e39d56afb6a10194303483552f28f07e5d7b7c5d470de554d92723c8d3c0d5d5a98fc44d23aa9d51bfda51e7d7cbb48fc4d1e3ac82150aeb4ce3e1616695225a WHIRLPOOL 21a2fa2337a3e06a03413a38a593984e384fa4b56c77f7bf7674d5ffa82b158d7a6433349b974e4c0ce2146bc99a5ea332980eb21a8428057f575ac5b2a3db8c
DIST tor-0.3.0.8.tar.gz 5796845 SHA256 663a3ba7b8a124c0f8a7351eaa2dda6fd518de3f3c4ee28fff869bfb03860d48 SHA512 93267e51578266f6f6eea57e7fcd7ec5f8fbeb2e880675956724a0b1c1dfe1826945aaba4ca3075b577505d0ce70fd7def2f2a9e06af78f52190e15a7aad2ee1 WHIRLPOOL a301811a7cf7dbd444a16802dcece32dbd679895e6bf45ad7c51787171a4d80d51a438585e5a1f9e1da55405537b706fafc3a6565f72bf08e89608a4fde98b85
DIST tor-0.3.0.9.tar.gz 5811303 SHA256 48d4880bf6ccb19ce9af2abde6946d7cf0635cc807548badbf4a221a79581e42 SHA512 19b662840ee0c6aaba04c6db7f172def070d0773553f90bc3d1f210266bbcb572b3dd1f383359e36583103235a85a0a4052cf7299a534fde137bee41376ffa02 WHIRLPOOL dc834c84207714a1fe9376dabe34651e506e93526e7f94de822d3691c4947c2332635b10127be5fa23d31adc5f9e1bc93ad65d1dcb7241a68a0459dffa2c6cb6
DIST tor-0.3.1.5-alpha.tar.gz 5997514 SHA256 04281b87e8b97517ba52232cd58de06a816f5a136b9b7a7316be878b36df8313 SHA512 5c96b0978e8cb15bd76dc171079451439c4e25d2fbd6f817d58a7bd786d494a7ed7e18931acf046cfb9ee12c5342e212b1faa69b8eb9207db1e791dcc4f3221d WHIRLPOOL 909b31e2d3a774781e94ffdd7a892bdde931c8a876fd811fd745e2f03445be2e735df1b049615a7be3f4a193fe40d317bd75376d164abcf3d6eee126d96049e1
74 changes: 74 additions & 0 deletions net-vpn/tor/tor-0.3.0.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit flag-o-matic readme.gentoo-r1 systemd versionator user

MY_PV="$(replace_version_separator 4 -)"
MY_PF="${PN}-${MY_PV}"
DESCRIPTION="Anonymizing overlay network for TCP"
HOMEPAGE="http://www.torproject.org/"
SRC_URI="https://www.torproject.org/dist/${MY_PF}.tar.gz
https://archive.torproject.org/tor-package-archive/${MY_PF}.tar.gz"
S="${WORKDIR}/${MY_PF}"

LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
IUSE="libressl scrypt seccomp selinux systemd tor-hardening test web"

DEPEND="
app-text/asciidoc
dev-libs/libevent[ssl]
sys-libs/zlib
!libressl? ( dev-libs/openssl:0=[-bindist] )
libressl? ( dev-libs/libressl:0= )
scrypt? ( app-crypt/libscrypt )
seccomp? ( sys-libs/libseccomp )
systemd? ( sys-apps/systemd )"
RDEPEND="${DEPEND}
selinux? ( sec-policy/selinux-tor )"

PATCHES=(
"${FILESDIR}"/${PN}-0.2.7.4-torrc.sample.patch
)

DOCS=( README ChangeLog ReleaseNotes doc/HACKING )

pkg_setup() {
enewgroup tor
enewuser tor -1 -1 /var/lib/tor tor
}

src_configure() {
econf \
--localstatedir="${EPREFIX}/var" \
--enable-system-torrc \
--enable-asciidoc \
$(use_enable scrypt libscrypt) \
$(use_enable seccomp) \
$(use_enable systemd) \
$(use_enable tor-hardening gcc-hardening) \
$(use_enable tor-hardening linker-hardening) \
$(use_enable web tor2web-mode) \
$(use_enable test unittests) \
$(use_enable test coverage)
}

src_install() {
default
readme.gentoo_create_doc

newconfd "${FILESDIR}"/tor.confd tor
newinitd "${FILESDIR}"/tor.initd-r8 tor
systemd_dounit contrib/dist/tor.service

keepdir /var/lib/tor

fperms 750 /var/lib/tor
fowners tor:tor /var/lib/tor

insinto /etc/tor/
newins "${FILESDIR}"/torrc-r1 torrc
}

0 comments on commit 0fcaa6e

Please sign in to comment.