forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/python-spidermonkey: add python-spidermonkey-0.0.10
Package-Manager: portage-2.2.26
- Loading branch information
Showing
4 changed files
with
57 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST python-spidermonkey-0.0.10.tar.gz 787526 SHA256 5409546a68b794a398f8598eddfeb4274559376c54c84c8b752798391712d889 SHA512 e3d45ba2e747f8f382e273962f8015be8e736cbd49246864d894d7db1d436c9e14c5e945f4bd3cf3a7aca8d4f60d0f57855704c5d2cac94630df26e67898f591 WHIRLPOOL 5d6be4f176450005a8cd14cbe9fcebbc38f0750e6366e6860471b0d2f0ece91e75c5d14840f99080b8b49c413b71588edbef11605aea0b0dab4b5eecfbe130dd |
12 changes: 12 additions & 0 deletions
12
dev-python/python-spidermonkey/files/python-spidermonkey-0.0.10-tests.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
diff --git a/tests/test-syntax-error.py b/tests/test-syntax-error.py | ||
index ab14deb..78fc0ed 100644 | ||
--- a/tests/test-syntax-error.py | ||
+++ b/tests/test-syntax-error.py | ||
@@ -9,7 +9,3 @@ import traceback | ||
def test_syntax_error(cx): | ||
t.raises(t.JSError, cx.execute, "function(asdf;") | ||
|
||
-@t.cx() | ||
-def test_invalid_octal(cx): | ||
- t.raises(t.JSError, cx.execute, "09;") | ||
- |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="person"> | ||
<email>[email protected]</email> | ||
<name>Austin English</name> | ||
</maintainer> | ||
<longdescription> | ||
JavaScript / Python bridge | ||
</longdescription> | ||
<upstream> | ||
<remote-id type="pypi">python-spidermonkey</remote-id> | ||
<remote-id type="github">davisp/python-spidermonkey</remote-id> | ||
</upstream> | ||
</pkgmetadata> |
29 changes: 29 additions & 0 deletions
29
dev-python/python-spidermonkey/python-spidermonkey-0.0.10.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,29 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
PYTHON_COMPAT=(python2_7) | ||
inherit distutils-r1 | ||
|
||
DESCRIPTION="JavaScript / Python bridge" | ||
HOMEPAGE="http://github.com/davisp/python-spidermonkey" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
IUSE="test" | ||
|
||
CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]" | ||
DEPEND="${CDEPEND} | ||
dev-libs/nspr | ||
>=dev-python/nose-0.10.0[${PYTHON_USEDEP}]" | ||
RDEPEND="${CDEPEND}" | ||
|
||
PATCHES=("${FILESDIR}"/${P}-tests.patch) | ||
|
||
python_test() { | ||
esetup.py test | ||
} |