Skip to content

Commit

Permalink
sci-libs/libint: compile with support derivatives
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Christoph Junghans <[email protected]>
  • Loading branch information
junghans committed Oct 13, 2020
1 parent defb45b commit 0ffa139
Showing 1 changed file with 57 additions and 0 deletions.
57 changes: 57 additions & 0 deletions sci-libs/libint/libint-2.6.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools eutils fortran-2 toolchain-funcs

DESCRIPTION="Matrix elements (integrals) evaluation over Cartesian Gaussian functions"
HOMEPAGE="https://github.com/evaleev/libint"
SRC_URI="https://github.com/evaleev/libint/archive/v${PV}.tar.gz -> ${P}.tar.gz"

SLOT="2"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="static-libs doc"

DEPEND="
dev-libs/boost
dev-libs/gmp[cxx]
doc? (
dev-texlive/texlive-latex
dev-tex/latex2html
)"

src_prepare() {
default
eautoreconf
}

src_configure() {
econf \
--with-cxx=$(tc-getCXX) \
--with-cxx-optflags="${CXXFLAGS}" \
--with-cxxgen-optflags="${CXXFLAGS}" \
--with-cxxdepend=$(tc-getCXX) \
--with-ranlib=$(tc-getRANLIB) \
--with-ar=$(tc-getAR) \
--with-ld=$(tc-getLD) \
--enable-eri3=1
$(use_enable static-libs static)
}

src_compile() {
emake LDFLAGS="${LDFLAGS}"

use doc && emake html pdf
}

src_install() {
default

if use doc; then
DOCS=( doc/progman/progman.pdf )
HTML_DOCS=( doc/progman/progman/*.{html,png,css} )
einstalldocs
fi
}

0 comments on commit 0ffa139

Please sign in to comment.