Skip to content

Commit

Permalink
dev-util/bazel: Bump to version 3.7.2
Browse files Browse the repository at this point in the history
Reported-by: Hans de Graaff <[email protected]>
Closes: https://bugs.gentoo.org/783132
Package-Manager: Portage-3.0.18, Repoman-3.0.3
Signed-off-by: Zac Medico <[email protected]>
  • Loading branch information
zmedico committed Apr 16, 2021
1 parent bcfc967 commit 100595f
Show file tree
Hide file tree
Showing 2 changed files with 114 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/bazel/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -9,3 +9,4 @@ DIST bazel-1.2.0-rename-gettid-functions.patch 3303 BLAKE2B 75aaed0b8e5fe33910d1
DIST bazel-1.2.1-dist.zip 267514406 BLAKE2B f9d316ac096f503a2c7fe101b103b88e7f0247f767a8dc28eb8c9d2cd0b6df6fa785f3b187e1a3963e2f9f0ae742a3330e5104e7a8aea75cb9b9e100366a5aca SHA512 bc0e6526bfbb8725a4f2ae95fc88b22229301b64559325fca3bcf5a9bc642cec2b2284eb9a6ce0699f1f910378b89ee23657dbea7928a92cc1900f1f2f405ff3
DIST bazel-2.0.0-dist.zip 259625808 BLAKE2B 31b62fb3da1f6fc7efc4c3f44521e12f879a1e5b532fe814d8f49c01c511b34cd65df252d6d143fdcd96f72dc94d76249f79be50fc66a459132c030ef0182ca8 SHA512 db609e9d0ee0cdbfb999de850db17907af02dc26e605f4617dfeb2fbac5c30c4c0a9f48c6ba3673ffe8babb5b9e157cc51c32832015b85ed279b6b160506cdae
DIST bazel-3.2.0-dist.zip 269368916 BLAKE2B 1eb54c42e22432d2c836a87179094563b797744de423468bf9bce1b7b4dbcdce20e033ed03c4cd7ea5026c9e0d971e16202aff09f9c45d91c9fc53af6f0f8802 SHA512 fd8191188ecb49087b2b474bc383b2bb5d131460952be64b8930dc7e573fd14f99f231c4270b88fb4c9537fb94a04588fb580891519d20c7b90d705238f17f81
DIST bazel-3.7.2-dist.zip 313677756 BLAKE2B cd6363762c68d25739a6bf6c13f10e191302a10b6fb7d97455effbc678d4f0b644c76115cad478aad7c09f703d9e594f4bdb8669ed6ab97d6a559a27723c510c SHA512 e8746ef5ec22feb95e9dbbddb3fb56cf8f49c80f326fc2a4e0ce2619607826fac22f46bfb995daee55bf9ffabb9d646b8454be2bce7b479da5cf2a7e5b3be62b
113 changes: 113 additions & 0 deletions dev-util/bazel/bazel-3.7.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,113 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit bash-completion-r1 java-pkg-2 multiprocessing

DESCRIPTION="Fast and correct automated build system"
HOMEPAGE="https://bazel.build/"

SRC_URI="https://github.com/bazelbuild/bazel/releases/download/${PV}/${P}-dist.zip"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="examples tools prefix static-libs"
REQUIRED_USE="prefix? ( static-libs )"
# strip corrupts the bazel binary
# test fails with network-sandbox: An error occurred during the fetch of repository 'io_bazel_skydoc' (bug 690794)
RESTRICT="strip test"
RDEPEND=">=virtual/jdk-1.8:*"
DEPEND="${RDEPEND}
app-arch/unzip
app-arch/zip"

S="${WORKDIR}"

bazel-get-flags() {
local i fs=()
for i in ${CFLAGS}; do
fs+=( "--copt=${i}" "--host_copt=${i}" )
done
for i in ${CXXFLAGS}; do
fs+=( "--cxxopt=${i}" "--host_cxxopt=${i}" )
done
for i in ${CPPFLAGS}; do
fs+=( "--copt=${i}" "--host_copt=${i}" )
fs+=( "--cxxopt=${i}" "--host_cxxopt=${i}" )
done
for i in ${LDFLAGS}; do
fs+=( "--linkopt=${i}" "--host_linkopt=${i}" )
done
echo "${fs[*]}"
}

pkg_setup() {
echo ${PATH} | grep -q ccache && \
ewarn "${PN} usually fails to compile with ccache, you have been warned"
java-pkg-2_pkg_setup
}

src_unpack() {
# Only unpack the main distfile
unpack ${P}-dist.zip
}

src_prepare() {
default

# F: fopen_wr
# S: deny
# P: /proc/self/setgroups
# A: /proc/self/setgroups
# R: /proc/24939/setgroups
# C: /usr/lib/systemd/systemd
addpredict /proc
}

src_compile() {
export EXTRA_BAZEL_ARGS="--jobs=$(makeopts_jobs) $(bazel-get-flags) --host_javabase=@local_jdk//:jdk"
if use static-libs; then
export BAZEL_LINKOPTS=-static-libs:-static-libgcc BAZEL_LINKLIBS=-l%:libstdc++.a:-lm
fi
VERBOSE=yes ./compile.sh || die

./scripts/generate_bash_completion.sh \
--bazel=output/bazel \
--output=bazel-complete.bash \
--prepend=scripts/bazel-complete-header.bash \
--prepend=scripts/bazel-complete-template.bash
}

src_test() {
output/bazel test \
--verbose_failures \
--spawn_strategy=standalone \
--genrule_strategy=standalone \
--verbose_test_summary \
examples/cpp:hello-success_test || die
output/bazel shutdown
}

src_install() {
dobin output/bazel
newbashcomp bazel-complete.bash ${PN}
bashcomp_alias ${PN} ibazel
insinto /usr/share/zsh/site-functions
doins scripts/zsh_completion/_bazel

if use examples; then
docinto examples
dodoc -r examples/*
docompress -x /usr/share/doc/${PF}/examples
fi
# could really build tools but I don't know which ones
# are actually used
if use tools; then
docinto tools
dodoc -r tools/*
docompress -x /usr/share/doc/${PF}/tools
docompress -x /usr/share/doc/${PF}/tools/build_defs/pkg/testdata
fi
}

0 comments on commit 100595f

Please sign in to comment.