Skip to content

Commit

Permalink
games-mud/tf: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Aug 5, 2016
1 parent acd59c1 commit 102d0c6
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 3 deletions.
6 changes: 3 additions & 3 deletions games-mud/tf/files/tf-50_beta8-stdarg.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
diff -U5 -r tf-50b8.orig/src/tfio.c tf-50b8/src/tfio.c
--- src/tfio.c.orig 2007-01-13 18:12:39.000000000 -0500
+++ src/tfio.c 2007-02-02 16:50:12.000000000 -0500
diff -U5 -r a/src/tfio.c b/src/tfio.c
--- a/src/tfio.c 2007-01-13 18:12:39.000000000 -0500
+++ b/src/tfio.c 2007-02-02 16:50:12.000000000 -0500
@@ -495,10 +495,11 @@
const char *q, *sval;
char *specptr, quote;
Expand Down
72 changes: 72 additions & 0 deletions games-mud/tf/tf-50_beta8-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

MY_P="${P/_beta/b}"
DESCRIPTION="A small, flexible, screen-oriented MUD client (aka TinyFugue)"
HOMEPAGE="http://tinyfugue.sourceforge.net/"
SRC_URI="mirror://sourceforge/tinyfugue/${MY_P}.tar.gz
http://homepage.mac.com/mikeride/abelinc/scripts/allrootpatch.txt ->
tf-allrootpatch.txt
http://homepage.mac.com/mikeride/abelinc/scripts/allsrcpatch.txt ->
tf-allsrcpatch.txt
doc? ( mirror://sourceforge/tinyfugue/${MY_P}-help.tar.gz )"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="+atcp debug doc +gmcp ipv6 +option102 ssl"

RDEPEND="ssl? ( dev-libs/openssl:0= )
dev-libs/libpcre"
DEPEND=${RDEPEND}

S=${WORKDIR}/${MY_P}

PATCHES=(
"${DISTDIR}"/tf-all*patch.txt
"${FILESDIR}"/${P}-pcre.patch
"${FILESDIR}"/${P}-stdarg.patch
)

src_configure() {
STRIP=: econf \
$(use_enable atcp) \
$(use_enable gmcp) \
$(use_enable option102) \
$(use_enable ssl) \
$(use_enable debug core) \
$(use_enable ipv6 inet6) \
--enable-manpage
}

src_install() {
dobin src/tf
newman src/tf.1.nroffman tf.1
dodoc CHANGES CREDITS README

insinto "${GAMES_DATADIR}"/${PN}-lib
# the application looks for this file here if /changes is called.
# see comments on bug #23274
doins CHANGES
insopts -m0755
doins tf-lib/*
if use doc ; then
cd ../${MY_P}-help
dodoc -r *.html commands topics
cd ../${MY_P}
fi
}

pkg_postinst() {
use ipv6 && {
echo
ewarn "You have merged TinyFugue with IPv6-support."
ewarn "Support for IPv6 is still being experimental."
ewarn "If you experience problems with connecting to hosts,"
ewarn "try re-merging this package with USE="-ipv6""
echo
}
}

0 comments on commit 102d0c6

Please sign in to comment.