Skip to content

Commit

Permalink
dev-scheme/guile: version bump 2.2.3
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/614966
Package-Manager: Portage-2.3.13, Repoman-2.3.3
  • Loading branch information
Amynka committed Dec 4, 2017
1 parent d84b8b4 commit 104e1c9
Show file tree
Hide file tree
Showing 3 changed files with 87 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-scheme/guile/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST guile-1.8.8.tar.gz 3956654 SHA256 c3471fed2e72e5b04ad133bbaaf16369e8360283679bcf19800bc1b381024050 SHA512 ede6feb90cd419d8763feb8c5169275490a653919573c4dfced025b74cf591072b3a10ffb9a3f6ee3fe7b0a0956ffcf434e0859b421455c8349cea56bf427db0 WHIRLPOOL 104810030b5dae16805595a5b398e5a7e600771b64b08d5ff686036e2f273dcec3829a16e4cdb1dbb9db5813f2e225476f83e0535a789bc570fc2fc15a76dbe2
DIST guile-2.0.13.tar.gz 7808173 SHA256 ee8073c4582bb4f06412452fdf5dd185aae607441f1313c824f44bdd668b0bde SHA512 79fd5fda5064331eb687934ec3eaf07943f5b23bd05fbce23ab5ee3698864250b33746e33b8f074692b56f7b428dac42ed5d3f5b9dc17d171aa6dfadc1625b00 WHIRLPOOL 5f8b8e0f0e5fd2cde8fd4b1ca89ebe0231dd5f746945d71412a9d1ce57094013882972d9791511ef47e9bf1f2e9eff77a515dab8b4a6c0316122cb9ef49b5a7d
DIST guile-2.0.14.tar.gz 7823099 BLAKE2B e7fa5a4ca19dc4adfcc151350b0ed4e211b8470b0d12f65451697a818c3139a4a5992a019bd213114748230cb15ec755d1af70d42b901230854915c0ee7b05de SHA512 d69c9bdf589fedcc227f3203012f6ed11c327cef3a0147d8e016fe276abecdb4272625efe1d0c7aa68219fe8f29bbced44089a4b479e4eafe01976c6b2b83633
DIST guile-2.2.3.tar.gz 17266587 BLAKE2B 68751b881bca53e7ab04038483aa8c5a689978d1017e4c944a8142e301e2e13d5ffd2aba73f7b0aa27efd84d068558b96a88452d1e0b79dc04db1921e22a621d SHA512 31df17d28177badf63e1eb0d0d64e6a4d2abe64d4d5e69d8ff33a24dfb10abd25109ea9abfa86f5ff303b43665eb5b8127927f683f3b16139c5b3dc99f06f6fd
10 changes: 10 additions & 0 deletions dev-scheme/guile/files/guile-2.2.3-gentoo-sandbox.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
diff --git a/test-suite/standalone/test-out-of-memory b/test-suite/standalone/test-out-of-memory
index 2216512..0ed6079 100755
--- a/test-suite/standalone/test-out-of-memory
+++ b/test-suite/standalone/test-out-of-memory
@@ -5,2 +5,5 @@ exec guile -q -s "$0" "$@"

+; Gentoo's sandbox does not handle OOM gracefully
+(exit 77)
+
(unless (defined? 'setrlimit)
76 changes: 76 additions & 0 deletions dev-scheme/guile/guile-2.2.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit flag-o-matic

DESCRIPTION="GNU Ubiquitous Intelligent Language for Extensions"
HOMEPAGE="https://www.gnu.org/software/guile/"
SRC_URI="mirror://gnu/guile/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
LICENSE="LGPL-3+"
IUSE="debug debug-malloc +deprecated +networking +nls +regex +threads" # upstream recommended +networking +nls
# emacs useflag removal not working

# workaround for bug 596322
REQUIRED_USE="regex"

RDEPEND="
>=dev-libs/boehm-gc-7.0[threads?]
dev-libs/gmp:=
virtual/libffi
dev-libs/libltdl:=
dev-libs/libunistring:0=
sys-devel/libtool
sys-libs/ncurses:0=
sys-libs/readline:0="
DEPEND="${RDEPEND}
virtual/pkgconfig
sys-apps/texinfo
sys-devel/gettext"

SLOT="12/2.2-1" # libguile-2.2.so.1 => 2.2-1
MAJOR="2.2"
STRIP_MASK="*.go"

DOCS=( GUILE-VERSION HACKING README )

PATCHES=( "${FILESDIR}/${P}-gentoo-sandbox.patch" )

src_configure() {
# see bug #178499
filter-flags -ftree-vectorize

econf \
--disable-error-on-warning \
--disable-rpath \
--disable-static \
--enable-posix \
--without-libgmp-prefix \
--without-libiconv-prefix \
--without-libintl-prefix \
--without-libltdl-prefix \
--without-libreadline-prefix \
--without-libunistring-prefix \
$(use_enable debug guile-debug) \
$(use_enable debug-malloc) \
$(use_enable deprecated) \
$(use_enable networking) \
$(use_enable nls) \
$(use_enable regex) \
$(use_with threads)
}

src_install() {
default

# From Novell
# https://bugzilla.novell.com/show_bug.cgi?id=874028#c0
dodir /usr/share/gdb/auto-load/$(get_libdir)
mv "${ED}"/usr/$(get_libdir)/libguile-*-gdb.scm "${ED}"/usr/share/gdb/auto-load/$(get_libdir) || die

# necessary for registering slib, see bug 206896
keepdir /usr/share/guile/site

find "${D}" -name '*.la' -delete || die
}

0 comments on commit 104e1c9

Please sign in to comment.