Skip to content

Commit

Permalink
dev-libs/libintl: version bump to 0.19.7
Browse files Browse the repository at this point in the history
  • Loading branch information
vapier committed Jan 28, 2016
1 parent a0e218b commit 1056b87
Show file tree
Hide file tree
Showing 2 changed files with 77 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libintl/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gettext-0.19.6.tar.gz 18619659 SHA256 ed4b4c19bd3a3034eb6769500a3592ff616759ef43cf30586dbb7a17c9dd695d SHA512 46adfd4a6d0038aba999658bebe51117e3ab3dc149a9054c1087d3e79ec7ba3371a7e78a8ca30a8872d162c2dc44aba6e67e4d64808c4f92e1e2bd674174f1db WHIRLPOOL 1988f9ddfd603734b4a632291925c8e5b31e7384eea1c6641d52aa58cb6b8f892e7664dd145a53435b7d2a4540ac65aeae1cb528a004c35832087c2820dafbcb
DIST gettext-0.19.7.tar.gz 19235781 SHA256 5386d2a40500295783c6a52121adcf42a25519e2d23675950619c9e69558c23f SHA512 7ba89074d3eddd0b4a5e2980e1ec74b53c49b7a04a1fa91c70c4bc11ce9c30415e4df9d79698148eaaed325fb4feb25a340a2e8e01fbe86b1a66b1376a4c9e3d WHIRLPOOL eb51c4be7c0a92c5c33c16329003e21947e0b9d1583c4a785ae6836f81273ea7ec2823a0a28ae81c3b977f2148c0f3bd524949484383ff87510e1d2bc642a786
76 changes: 76 additions & 0 deletions dev-libs/libintl/libintl-0.19.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

# Note: Keep version bumps in sync with sys-devel/gettext.

EAPI="5"

MY_P="gettext-${PV}"

inherit multilib-minimal toolchain-funcs libtool

DESCRIPTION="the GNU international library (split out of gettext)"
HOMEPAGE="https://www.gnu.org/software/gettext/"
SRC_URI="mirror://gnu/gettext/${MY_P}.tar.gz"

LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
IUSE="static-libs +threads"

DEPEND=">=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]"
# Block C libraries known to provide libintl.
RDEPEND="${DEPEND}
!sys-libs/glibc
!<sys-devel/gettext-0.19.6-r1"

S="${WORKDIR}/${MY_P}/gettext-runtime"

src_prepare() {
# The libtool files are stored higher up, so make sure we run in the
# whole tree and not just the subdir we build.
elibtoolize "${WORKDIR}"
}

multilib_src_configure() {
local myconf=(
# Emacs support is now in a separate package.
--without-emacs
--without-lispdir
# Normally this controls nls behavior in general, but the libintl
# subdir is skipped unless this is explicitly set. ugh.
--enable-nls
# This magic flag enables libintl.
--with-included-gettext
# The gettext package provides this library.
--disable-c++
--disable-libasprintf
# No java until someone cares.
--disable-java

$(use_enable static-libs static)
$(use_enable threads)
)
ECONF_SOURCE=${S} econf "${myconf[@]}"
}

multilib_src_compile() {
# We only need things in the intl/ subdir.
emake -C intl
}

multilib_src_install() {
# We only need things in the intl/ subdir.
emake DESTDIR="${D}" install -C intl

gen_usr_ldscript -a intl
}

multilib_src_install_all() {
use static-libs || prune_libtool_files --all

rm -f "${ED}"/usr/share/locale/locale.alias "${ED}"/usr/lib/charset.alias

dodoc AUTHORS ChangeLog NEWS README
}

0 comments on commit 1056b87

Please sign in to comment.