Skip to content

Commit

Permalink
games-arcade/xrick: Port to EAPI 7
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/707136
Package-Manager: Portage-3.0.9, Repoman-3.0.2
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Nov 22, 2020
1 parent 5a362eb commit 1073cfb
Show file tree
Hide file tree
Showing 3 changed files with 89 additions and 17 deletions.
30 changes: 30 additions & 0 deletions games-arcade/xrick/files/xrick-021212-Makefile.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
--- a/Makefile
+++ b/Makefile
@@ -71,10 +71,8 @@
all:
@echo "ROOTDIR=$(ROOTDIR)" > Makefile.global
@echo "XOBJ=$(XOBJ)" >> Makefile.global
- @echo "CFLAGS=-g -ansi -pedantic -Wall -W -O2 -I $(ROOTDIR)/include $(shell sdl-config --cflags)" >> Makefile.global
- @echo "LDFLAGS=-lz $(shell sdl-config --libs)" >> Makefile.global
- @echo "CC=gcc" >> Makefile.global
- @echo "CPP=gcc -E" >> Makefile.global
+ @echo "CFLAGS+=-pedantic -Wall -I$(ROOTDIR)/include $(shell sdl-config --cflags)" >> Makefile.global
+ @echo "LIBS+=-lz $(shell sdl-config --libs)" >> Makefile.global
$(MAKE) -C src all

clean:
--- a/src/Makefile
+++ b/src/Makefile
@@ -40,10 +40,10 @@
all: $(TARGET)

$(TARGET): $(OBJECTS) $(XOBJ)
- $(CC) $(OBJECTS) $(XOBJ) $(LDFLAGS) -o $(TARGET)
+ $(CC) $(LDFLAGS) $(OBJECTS) $(XOBJ) -o $(TARGET) $(LIBS)

%.o: %.c
- $(CC) $(CFLAGS) -c $< -o $@
+ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@

xrick.res: xrick.rc
windres $< -O coff -o $@
34 changes: 34 additions & 0 deletions games-arcade/xrick/files/xrick-021212-fno-common.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
--- a/include/img.h
+++ b/include/img.h
@@ -27,7 +27,7 @@
U8 *pixels;
} img_t;

-img_t *IMG_SPLASH;
+extern img_t *IMG_SPLASH;

#endif

--- a/src/dat_snd.c
+++ b/src/dat_snd.c
@@ -19,14 +19,14 @@

sound_t *WAV_WAA;
sound_t *WAV_BOMB;
-sound_t *WAV_BULLET;
-sound_t *WAV_WALK;
-sound_t *WAV_JUMP;
+extern sound_t *WAV_BULLET;
+extern sound_t *WAV_WALK;
+extern sound_t *WAV_JUMP;
sound_t *WAV_TING;
-sound_t *WAV_BOMBSHHT;
-sound_t *WAV_BONUS;
+extern sound_t *WAV_BOMBSHHT;
+extern sound_t *WAV_BONUS;
sound_t *WAV_SHHT;
-sound_t *WAV_BOX;
+extern sound_t *WAV_BOX;
sound_t *WAV_DDDING;

#endif /* ENABLE_SOUND */
42 changes: 25 additions & 17 deletions games-arcade/xrick/xrick-021212-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit desktop
EAPI=7

inherit desktop toolchain-funcs

DESCRIPTION="Clone of the Rick Dangerous adventure game from the 80's"
HOMEPAGE="http://www.bigorno.net/xrick/"
Expand All @@ -11,44 +12,51 @@ SRC_URI="http://www.bigorno.net/xrick/${P}.tgz"
LICENSE="GPL-1+ xrick"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE=""
RESTRICT="mirror bindist" # bug #149097

DEPEND="media-libs/libsdl[video]"
RDEPEND="${DEPEND}"

PATCHES=(
"${FILESDIR}"/${P}-exit.patch
"${FILESDIR}"/${P}-fullscreen.patch
"${FILESDIR}"/${P}-zlib.patch
"${FILESDIR}"/${P}-Makefile.patch
"${FILESDIR}"/${P}-fno-common.patch
)

src_unpack() {
unpack ${A}
cd "${S}"
cd "${S}" || die
unpack ./xrick.6.gz
}

src_prepare() {
default
eapply "${FILESDIR}"/${P}*.patch

sed -i \
-e "/^run from/d" \
-e "/data.zip/ s:the directory where xrick is:$(get_libdir)/${PN}.:" \
-e "/data.zip/ s:the directory where xrick is:$(get_libdir)/xrick.:" \
xrick.6 || die

sed -i \
-e "s:data.zip:/usr/$(get_libdir)/${PN}/data.zip:" \
-e "s:data.zip:${EPREFIX}/usr/$(get_libdir)/xrick/data.zip:" \
src/xrick.c || die
}

sed -i \
-e "s/-g -ansi -pedantic -Wall -W -O2/${CFLAGS}/" \
-e '/LDFLAGS/s/=/+=/' \
-e '/CC=/d' \
-e "/CPP=/ { s/gcc/\$(CC)/; s/\"/'/g }" \
Makefile || die
src_configure() {
tc-export CC
}

src_install() {
dobin xrick
insinto /usr/"$(get_libdir)"/${PN}

insinto /usr/$(get_libdir)/xrick
doins data.zip
newicon src/xrickST.ico ${PN}.ico
make_desktop_entry ${PN} ${PN} /usr/share/pixmaps/${PN}.ico

dodoc README KeyCodes
doman xrick.6

newicon src/xrickST.ico xrick.ico
make_desktop_entry xrick xrick /usr/share/pixmaps/xrick.ico
}

0 comments on commit 1073cfb

Please sign in to comment.