Skip to content

Commit

Permalink
sci-physics/lammps: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
nicolasbock committed Jan 25, 2016
1 parent f200e62 commit 1083979
Show file tree
Hide file tree
Showing 2 changed files with 219 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-physics/lammps/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,6 +5,7 @@ DIST lammps-11Sep15.tar.gz 87274144 SHA256 79a40bc395a9052345cf1c7caa8da69f6ec06
DIST lammps-15Jan16.tar.gz 85956338 SHA256 e90816bf20622200f5037415e5c45a0f950f7407886121708b794b1e75b93c3a SHA512 7dc2043afba78ec8d61b5880b6123952b42e5076fe7e3c3855186215054bc28710b89fd5b015d495fcfe38d5970efd43f3e6e834e80f39b6305b551d39f5eeab WHIRLPOOL 13bd3f41047492035c24e11d47b36ec8565d226738be492159ba498827c79eab4a7ec7402e037820b635b0d8d4c56fbdedea482f2f93e370275d717c93bc281c
DIST lammps-15May15.tar.gz 63835027 SHA256 0233ea98c7d77d31bd0a538bb674c0ee8f000f1d0ee1b8c049072873192aa228 SHA512 a23c16b98117590b15ca7662b878fb2f76ec41399c329c98deb48e28a0ffce293443269513a96c2503389894b598787b19dadc210d4b4dbc6a7432caf633e7d1 WHIRLPOOL 4c4edfd772bbf534e42fc43e1feaf3b8f76e74c58ec1e985e3c29ee0d8e64aa8c501b8e45e078643409c320a1d834b0d5eb699e7d1ec29df06be0126d12492f1
DIST lammps-20Nov15.tar.gz 90227651 SHA256 7c392c848e73335226b2fef6bb8034b1152f91862d955a3bae00502bf9d8e8fe SHA512 4bff70e45fb30be10a33b4c6c60b73cceddf8d42588b0630b4802f1e61dea3c237c01c3667585ad210ef2cdb811491b1b8495718a90bb57853c58245e29d1fe4 WHIRLPOOL a01f54911a5edb666ef5af5302cf60d61d58d20f2112578e4d7bd16787b2bf59da09e9fe7ffa021fb6a97db40b23301ed77010f48a05e5471742c0e71413b7e1
DIST lammps-22Jan16.tar.gz 85952234 SHA256 46425bf0ae73f716195a29dc9823c2c5989504f85b49a316bc304caaf6e6a674 SHA512 3ceeeaf76621bbc11ea25d5fb321b602b34ffb3893898a704b02e5cd428a36b2017006fdc1f7b1c5f957c33f26ca103a2939538ae7937555e0b25b5852cd48f3 WHIRLPOOL 7f61ea1924eceb190b7cf56ed32db75f6a45c99dbf1522862124f59acd1f79b1a46310d5e31a988011461a55c319677eaec2bf713e9a5cda0411b5d2280aa784
DIST lammps-22Oct15.tar.gz 87938562 SHA256 8376b52e8eef4d1c3628c15ff358ecf74303e308566f41fd055701f6af3b6484 SHA512 cbe61420cccd11cd444423214802dfd2d1b2b1b28511a53dbf22e993fa3592404e8dda29fcb7bcd4e6e2d1e2251ddc6f020d48bafa66c8fceaa27d4af2e21640 WHIRLPOOL 11d09b18ff742d6ac4fcb400df93d7ac29144ee554f7241e58da80d039a99ef23b4b81709170ed12215693de97b6b48c9a6967d7d0539fd7f2f172a1e0a83661
DIST lammps-23Oct15.tar.gz 87933918 SHA256 3500cdeb22344c7f3a040834a232d6c5ddb9f601820794441fcc24dadedc49b6 SHA512 a26d214b3e7c47d63cf00a364753a829d1c8f0cf4f8b73e829a4463650303d6905b6c942df5890387413b44496c8615b286296b34df9181e54806bb2f361b39a WHIRLPOOL 9a2d6e8fb57f1af2969345d9b250ed1244d2e40c97d5e2994c0ef6225ca265b490809848faa7cdc29a3eaa7c51a6223320039863f6c382a1a51da6f474e52088
DIST lammps-24Sep15.tar.gz 87307191 SHA256 e03cdeb2b3b6107d98969febea26575c85590603ab4f79d26efc46bac6d6cc60 SHA512 356dd556f845cec456865062375120c0898cef1870617d80b31b0e8e964585140120b21f891cd9b40ecde7aaf43beb34d7b15396830e08273624a9b14da551e4 WHIRLPOOL 667b8aaf927d268c569a192c835b7dbdc80a0f25abb1f2c96007517ea218a69b2816dde4ebe28ca82974d01472c0e1126b67e89a19fb3ef49e4020f3d9c69fba
Expand Down
218 changes: 218 additions & 0 deletions sci-physics/lammps/lammps-20160122.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,218 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python{2_7,3_3,3_4} )

inherit eutils flag-o-matic fortran-2 multilib python-r1

convert_month() {
local months=( "" Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec )
echo ${months[${1#0}]}
}

MY_P=${PN}-$((10#${PV:6:2}))$(convert_month ${PV:4:2})${PV:2:2}

DESCRIPTION="Large-scale Atomic/Molecular Massively Parallel Simulator"
HOMEPAGE="http://lammps.sandia.gov/"
SRC_URI="http://lammps.sandia.gov/tars/${MY_P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples gzip lammps-memalign mpi python static-libs"

# blas/lapack is needed by the ATC package which is only built with MPI.
DEPEND="
gzip? ( app-arch/gzip )
mpi? (
virtual/blas
virtual/lapack
virtual/mpi
)
python? ( ${PYTHON_DEPS} )
sci-libs/voro++
"
RDEPEND="${DEPEND}"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

S="${WORKDIR}/${MY_P}"

lmp_emake() {
local LAMMPS_INCLUDEFLAGS
LAMMPS_INCLUDEFLAGS="$(usex gzip '-DLAMMPS_GZIP' '')"
LAMMPS_INCLUDEFLAGS+="$(usex lammps-memalign ' -DLAMMPS_MEMALIGN=64' '')"

# The lammps makefile uses CC to indicate the C++ compiler.
emake \
ARCHIVE="$(tc-getAR)" \
CC="$(usex mpi "mpic++" "$(tc-getCXX)")" \
F90="$(usex mpi "mpif90" "$(tc-getFC)")" \
LINK="$(usex mpi "mpic++" "$(tc-getCXX)")" \
CCFLAGS="${CXXFLAGS}" \
F90FLAGS="${FCFLAGS}" \
LINKFLAGS="${LDFLAGS}" \
LMP_INC="${LAMMPS_INCLUDEFLAGS}" \
MPI_INC="$(usex mpi "" "-I../STUBS")" \
MPI_PATH="$(usex mpi "" "-L../STUBS")" \
MPI_LIB="$(usex mpi "" "-lmpi_stubs")" \
user-atc_SYSLIB="$(usex mpi "$($(tc-getPKG_CONFIG) --libs blas) $($(tc-getPKG_CONFIG) --libs lapack)" '')"\
"$@"
}

lmp_activate_packages() {
# Build packages
local packages=( yes-asphere yes-body yes-class2 yes-colloid \
yes-coreshell yes-dipole yes-fld yes-granular yes-kspace \
yes-manybody yes-mc yes-meam yes-misc \
$(usex mpi "yes-user-atc" "") \
yes-molecule yes-opt yes-peri yes-poems yes-qeq yes-reax \
yes-replica yes-rigid yes-shock yes-snap yes-srd \
yes-user-eff yes-user-fep \
$(usex mpi "yes-user-lb" "") \
yes-user-phonon yes-user-sph yes-voronoi yes-xtc )

for p in ${packages[@]}; do
lmp_emake -C src ${p}
done
}

lmp_build_packages() {
lmp_emake -C lib/meam -j1 -f Makefile.gfortran
lmp_emake -C lib/poems -f Makefile.g++
lmp_emake -C lib/reax -j1 -f Makefile.gfortran
use mpi && lmp_emake -C lib/atc -f Makefile.g++
}

lmp_clean_packages() {
lmp_emake -C lib/meam -f Makefile.gfortran clean
lmp_emake -C lib/poems -f Makefile.g++ clean
lmp_emake -C lib/reax -f Makefile.gfortran clean
use mpi && lmp_emake -C lib/atc -f Makefile.g++ clean
}

src_prepare() {
# Fix inconsistent use of SHFLAGS.
sed -i \
-e 's:voronoi_SYSINC\s\+=.*$:voronoi_SYSINC = -I/usr/include/voro++:' \
-e 's:voronoi_SYSPATH\s\+=.*$:voronoi_SYSPATH =:' \
lib/voronoi/Makefile.lammps || die

# Fix missing .so name.
sed -i \
-e 's:SHLIBFLAGS\s\+=\s\+:SHLIBFLAGS = -Wl,-soname,liblammps.so.0 :' \
src/MAKE/Makefile.serial || die

# Fix makefile in tools.
sed -i \
-e 's:g++:$(CXX) $(CXXFLAGS):' \
-e 's:gcc:$(CC) $(CCFLAGS):' \
-e 's:ifort:$(FC) $(FCFLAGS):' \
tools/Makefile || die

# Patch python.
epatch "${FILESDIR}/lammps-python3-r1.patch"
epatch "${FILESDIR}/python-shebang.patch"
}

src_compile() {
# Fix atc...
append-cxxflags -I../../src

# Acticate packages.
elog "Activating lammps packages..."
lmp_activate_packages

# STUBS/mpi.c is using '#include <mpi.h>' now instead of '#include
# "mpi.h"' which requires an additional '-I.'.
append-cxxflags -I.

# Compile stubs for serial version.
use mpi || lmp_emake -C src mpi-stubs

elog "Building packages..."
lmp_build_packages

if use static-libs; then
# Build static library.
elog "Building static library..."
lmp_emake -C src mode=lib serial
fi

# Clean out packages (that's not done by the build system with the clean
# target), so we can rebuild the packages with -fPIC.
elog "Cleaning packages..."
lmp_clean_packages

# The build system does not rebuild the packages with -fPIC, adding flag
# manually.
append-cxxflags -fPIC
append-fflags -fPIC

# Compile stubs for serial version.
use mpi || lmp_emake -C src mpi-stubs

elog "Building packages..."
lmp_build_packages

# Build shared library.
elog "Building shared library..."
lmp_emake -C src mode=shlib serial

# Compile main executable. The shared library is always built, and
# mode=shexe is simply a way to re-use the object files built in the
# "shlib" step when linking the executable. The executable is not actually
# using the shared library. If we have built the static library, then we
# link that into the executable.
elog "Linking executable..."
if use static-libs; then
lmp_emake -C src mode=exe serial
else
lmp_emake -C src mode=shexe serial
fi

# Compile tools.
elog "Building tools..."
lmp_emake -C tools binary2txt chain data2xmovie micelle2d
}

src_install() {
use static-libs && newlib.a src/liblammps_serial.a liblammps.a
newlib.so src/liblammps_serial.so liblammps.so.0.0.0
dosym liblammps.so.0.0.0 /usr/$(get_libdir)/liblammps.so
dosym liblammps.so.0.0.0 /usr/$(get_libdir)/liblammps.so.0
newbin src/lmp_serial lmp
dobin tools/binary2txt
dobin tools/chain
dobin tools/data2xmovie
dobin tools/micelle2d
# Don't forget to add header files of optional packages as they are added
# to this ebuild. There may also be .mod files from Fortran based
# packages.
insinto "/usr/include/${PN}"
doins -r src/*.h lib/meam/*.mod

local LAMMPS_POTENTIALS="usr/share/${PN}/potentials"
insinto "/${LAMMPS_POTENTIALS}"
doins potentials/*
echo "LAMMPS_POTENTIALS=${EROOT}${LAMMPS_POTENTIALS}" > 99lammps
doenvd 99lammps

# Install python script.
use python && python_foreach_impl python_domodule python/lammps.py

if use examples; then
local LAMMPS_EXAMPLES="/usr/share/${PN}/examples"
insinto "${LAMMPS_EXAMPLES}"
doins -r examples/*
fi

dodoc README
if use doc; then
dodoc doc/Manual.pdf
dohtml -r doc/*
fi
}

0 comments on commit 1083979

Please sign in to comment.