forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.2.26
- Loading branch information
Jeroen Roovers
committed
Jan 10, 2016
1 parent
9e9ec8a
commit 10adc1c
Showing
2 changed files
with
46 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST farbfeld-1.tar.gz 6770 SHA256 34faf878ee9bf20a690604b2e09f97ce517b20bb7b5e37433997941825c0b46e SHA512 cbd977175412ad7b143415643a3767b041e87d441f3bf9783872ffb48ed987f60156d6e2d7eff715071eb0349a3a131188487a1c9645dffa78966f0102b8405e WHIRLPOOL 6a6a489fcffda4b7c337097d51b181f7533a97a948af0c781cb035dba05b2b3ad892a1cde6f0dab05d3db893ddddfbf5666621144f4b8ed7e4a6981df3821343 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,45 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
inherit toolchain-funcs | ||
|
||
DESCRIPTION="farbfeld simple image format tools" | ||
HOMEPAGE="http://git.2f30.org/farbfeld/about/" | ||
SRC_URI="http://dl.suckless.org/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="ISC" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
|
||
RDEPEND=" | ||
media-libs/libjpeg-turbo | ||
media-libs/libpng:* | ||
" | ||
DEPEND=" | ||
${RDEPEND} | ||
" | ||
|
||
src_prepare() { | ||
sed config.mk \ | ||
-e '/^CC/d' \ | ||
-e 's|/usr/local|/usr|g' \ | ||
-e 's|^CFLAGS.*|CFLAGS += -std=c99 -pedantic -Wall -Wextra $(INCS) $(CPPFLAGS)|g' \ | ||
-e 's|^LDFLAGS.*|LDFLAGS += $(LIBS)|g' \ | ||
-e 's|{|(|g;s|}|)|g' \ | ||
-i || die | ||
|
||
sed Makefile \ | ||
-e 's|{|(|g;s|}|)|g' \ | ||
-e 's|^ @| |g' \ | ||
-i || die | ||
} | ||
|
||
src_compile() { | ||
emake CC=$(tc-getCC) | ||
} | ||
|
||
src_install() { | ||
emake DESTDIR="${D}" install MANPREFIX=/usr/share/man | ||
} |