Skip to content

Commit

Permalink
sys-kernel/vanilla-kernel: Bump to 5.5.17
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Apr 14, 2020
1 parent cf82aab commit 10cd32b
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-kernel/vanilla-kernel/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,6 +5,7 @@ DIST linux-5.4.24.arch1.i686.config 240684 BLAKE2B 8c29d083cef61f0c61e7256553c00
DIST linux-5.4.31.tar.xz 109511080 BLAKE2B d4feb08f0c84397c185551aa1d1220cede176d4c46904bde68492cf0db8d3bc8c3562de24b11674d23cc2850cdce2cf0bb77dcec962814f8b348690b566d7372 SHA512 0afd762ea25f5cfb0de26be30c67973f34902a7c2a1541b05921ce94e893a7a3a67f6c56b7b89ef5efd8f3b81a08197b479e28b57e53cfaf56c02fb00bcd95eb
DIST linux-5.4.32.tar.xz 109501416 BLAKE2B 0ac78d1eb97ce4689ccdab01fb1475d07f29a90251b44b05fcf030d2f9aa644ac9dbb1315c7fe1eb991ef1435b7f17669e2b4f66187e3404599a0f136d2b1a50 SHA512 197f292fa541031071b8ed64880a3d4251fa65059747cbdf3900b8f934d17f681b506ca5f70132899bdef343d2d249a7902215d2ea04af5410599f1e50d6cbac
DIST linux-5.5.16.tar.xz 110763424 BLAKE2B dd15f3d9c52356cae47c8c7bc57779fb8810afa3695daf207165f0508557d7d3a6cd92a1c023d86d264aee73503c10d32e8cedda1111ebf0202df48ae84f514d SHA512 018a01aea483b43cac2313bcaeddd85c59bf9f233106ffdb057b98f5c57a97205ff3fc7b80310cef04cd9fee61584ce82e0c14409cab4391bfc6ce396ebb5333
DIST linux-5.5.17.tar.xz 110755932 BLAKE2B 541210fd9b4f7229e63a6d38b6b857ca92c83509be1e0278ef76e9550c70b17e318d40bd5027c4793ca2bf232647a1021b21b80232cb9ad2fa1b5cc126eaceb7 SHA512 23a31092e2cb1e22b7bb2515accfaeeb15d5f4f17bec3315ee42c5043eef0238ffa90d237911adcf6ea1d99ebc1abe278ec51bc889a08aa159a5fecbf17ea663
DIST linux-5.5.5-arch1.amd64.config 243885 BLAKE2B 088e76a9981a64cd6163667fd09cc02148f15cc53812a429d1f5e22dc893823f57041e581ec957f38504c1fbb5aa0c7886847d1ea4cdc44d5ab245dcc304edc3 SHA512 e6958e1fd35e2a900fa6c81e68e35b42496e245829b8bfd85d9d351dcdf8bbea93d25a0edf74871beababb4ba28cd7a731e589e68e047ac972d973ea8c20d3ac
DIST linux-5.5.6-arch1.i686.config 243301 BLAKE2B c5fdd9dc2a0baed1ea421faa8f254d6ece47e89b78fc4c25c38369b53acc1f954978f2f86eda23b77d20a35096a596944f9c433db66008278ed2b8140823ce62 SHA512 b2d75bb1826a4dfad10aa5b6fa9cce2684d5de2dabc6da165e192e5a33cbd6eeaff4d7f236e074f4c099830e01e767bd6bc14a70d644057dce59288ae9704877
DIST tinycorelinux-10.1-amd64.qcow2 16842752 BLAKE2B e013e76503c335739a9623c0901ca791937a0e6b177854535cadec1e2c2cd2df588283ed3128cf652595f32264fbfe5b3bd3a8c97665fd4da344e308535be366 SHA512 c3aeb20ff8769da9211694b7f701907cc7ae7582cdfad2c2fdc008d97ebcbd9dc08245b4e8f8450e1cb304bd705345a11fe79f901a47979fee91443841d55641
Expand Down
65 changes: 65 additions & 0 deletions sys-kernel/vanilla-kernel/vanilla-kernel-5.5.17.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit kernel-build

MY_P=linux-${PV}
# https://git.archlinux.org/svntogit/packages.git/log/trunk/config?h=packages/linux
AMD64_CONFIG_VER=5.5.5-arch1
AMD64_CONFIG_HASH=e4d4ca36741d228042185e2a9047cd88fb5b4169
# https://git.archlinux32.org/packages/log/core/linux/config.i686
I686_CONFIG_VER=5.5.6-arch1
I686_CONFIG_HASH=7d53d8a42f68648bce5b002aaf8c2b14e6298275

DESCRIPTION="Linux kernel built from vanilla upstream sources"
HOMEPAGE="https://www.kernel.org/"
SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
amd64? (
https://git.archlinux.org/svntogit/packages.git/plain/trunk/config?h=packages/linux&id=${AMD64_CONFIG_HASH}
-> linux-${AMD64_CONFIG_VER}.amd64.config
)
x86? (
https://git.archlinux32.org/packages/plain/core/linux/config.i686?id=${I686_CONFIG_HASH}
-> linux-${I686_CONFIG_VER}.i686.config
)"
S=${WORKDIR}/${MY_P}

LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"

RDEPEND="
!sys-kernel/vanilla-kernel-bin:${SLOT}"

src_prepare() {
default

# prepare the default config
case ${ARCH} in
amd64)
cp "${DISTDIR}"/linux-${AMD64_CONFIG_VER}.amd64.config .config || die
;;
x86)
cp "${DISTDIR}"/linux-${I686_CONFIG_VER}.i686.config .config || die
;;
*)
die "Unsupported arch ${ARCH}"
;;
esac

local config_tweaks=(
# shove arch under the carpet!
-e 's:^CONFIG_DEFAULT_HOSTNAME=:&"gentoo":'
# we do support x32
-e '/CONFIG_X86_X32/s:.*:CONFIG_X86_X32=y:'
# disable signatures
-e '/CONFIG_MODULE_SIG/d'
-e '/CONFIG_SECURITY_LOCKDOWN/d'
# disable compression to allow stripping
-e '/CONFIG_MODULE_COMPRESS/d'
# disable gcc plugins to unbreak distcc
-e '/CONFIG_GCC_PLUGIN_STRUCTLEAK/d'
)
sed -i "${config_tweaks[@]}" .config || die
}

0 comments on commit 10cd32b

Please sign in to comment.