Skip to content

Commit

Permalink
dev-libs/ell: bump to 0.31
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Ben Kohler <[email protected]>
  • Loading branch information
benkohler committed Apr 14, 2020
1 parent dffdde4 commit 1106425
Show file tree
Hide file tree
Showing 2 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/ell/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST ell-0.26.tar.xz 473512 BLAKE2B bad1545b65caad7263e03156740ef5dfc401536fc063
DIST ell-0.27.tar.xz 474412 BLAKE2B 3b7d7ccfff8a92bbe930032b6a54bdc91b6541d1e6d8e514f1e49fcd08f3f5bc47beb3722dc864a63dcbbd72f793fbc2bc590b168f1623ff6e7088fbc960acb1 SHA512 ecda285155ef5ac1b8bdeabfba2e972149a5027c85236af74366c735aec7304b2dee8ff6aa931000b4299e8bb7654e7d4a63c1738de6e6e740f5ba16467f2823
DIST ell-0.28.tar.xz 474880 BLAKE2B 2c571f952056c9f4e3e8c245b2b57645c4baa2935fdbe758170dcfe689f4db2162322f25a80cc5a7d4d5bded6159d1fa0d583be979a2708d32e61e91d1ced585 SHA512 6c3aef4d403878c0c9b8a1e5e8861656f2abbab19dd275b1aecca899ca615c00aee30e18f194435ec6be859adcffbe3703a79b13508e1e76c2192ec51f7c0cd7
DIST ell-0.30.tar.xz 478204 BLAKE2B 77d1b7307949feb47da28e0c777172b9f5272676dc6fe677955118a9f8dfdaad43fc400e0057ae8b370ac441c61a21bc351fe89053e40d0d94f9874a3b373726 SHA512 e58ad67b8c6aca5294eb00cc194bac672f8666a445295f289e68462981bc07e5c2bce1297423470e1ba34cc2e2d10ee57741ce370e7c013991571ad1f685c6ff
DIST ell-0.31.tar.xz 478860 BLAKE2B f8f8d109605bf62396da001bd3d9b48fd6b7a6fc94ab890ab5a56fc8afb07a216b884fdf4b624ac8f39c3196de8149c7b32790da03262400aac6f8cd8b3fb56b SHA512 e304cc3bb1355fc0671412e793530503c83b1a036bfa3dd5b0cc36cfb28684b780293dc3d81a5727e0030743529882f71ac28d3c735860f6d46477e8ccf6a6e8
60 changes: 60 additions & 0 deletions dev-libs/ell/ell-0.31.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit flag-o-matic linux-info multilib-minimal

DESCRIPTION="Embedded Linux Library provides core, low-level functionality for system daemons"
HOMEPAGE="https://01.org/ell"
if [[ "${PV}" == *9999 ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://git.kernel.org/pub/scm/libs/ell/ell.git"
else
SRC_URI="https://mirrors.edge.kernel.org/pub/linux/libs/${PN}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
fi
LICENSE="LGPL-2.1"
SLOT="0"

IUSE="glib pie test"
RESTRICT="!test? ( test )"

RDEPEND="
glib? ( dev-libs/glib:2[${MULTILIB_USEDEP}] )
"
DEPEND="
${RDEPEND}
test? ( sys-apps/dbus )
"

CONFIG_CHECK="
~TIMERFD
~EVENTFD
~CRYPTO_USER_API
~CRYPTO_USER_API_HASH
~CRYPTO_MD5
~CRYPTO_SHA1
~KEY_DH_OPERATIONS
"

src_prepare() {
default
[[ "${PV}" == *9999 ]] && eautoreconf
}

multilib_src_configure() {
append-cflags "-fsigned-char" #662694
local myeconfargs=(
$(use_enable glib)
$(use_enable pie)
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}

multilib_src_install_all() {
local DOCS=( ChangeLog README )
einstalldocs

find "${ED}" -name "*.la" -delete || die
}

0 comments on commit 1106425

Please sign in to comment.