Skip to content

Commit

Permalink
dev-php/composer: bump to v2.0.9
Browse files Browse the repository at this point in the history
Closes: gentoo#18047
Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Feb 1, 2021
1 parent 72867ab commit 110f7ca
Show file tree
Hide file tree
Showing 3 changed files with 89 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/composer/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST composer-1.10.15.tar.gz 427919 BLAKE2B 38d2e1c795385dd13bedbf5283cf76b04efb54db8dc72eff05370b9505382e2e43f10e1528f148186edb759a098b948d1fee36ac99ab6a5591858723100a27aa SHA512 f8544632e00a08ec75b327e6eac2c96bff60ba78c238863c8ab6b4d82239997f11140a049df0d6c0338bb7523b52fc3ea6f767b9418f75b51535ccfde44fa68c
DIST composer-1.10.20.tar.gz 429016 BLAKE2B 29dcf1e32974230075e56c9b11e53316a1bada9a6ccf43f3357fc39577abadde566df962bb9bf92cc9806a012fbd70c18aba5daee87090fd10de273643d92ce7 SHA512 5b85ebc6a0612c01bd2dd6f6a57526581a821c1a45163ef85511bd0e629b10dc464776b56fe33be192b2a3f07ce818dc40cf2305d9f65ee10287b2265e198cca
DIST composer-2.0.9.tar.gz 493134 BLAKE2B f08818ec05aeebd79501e221b9cef10425c7dd60b9aca17ca8dad2f6967258d6b1a8d0d1b383b0c7dd1214ce6416f666bc30785bcb5978c66051ef2e03d17304 SHA512 4953bcc0d2e9ae61ebbb3615c262ac05762fa0165db2114118eb5c2bb014bc4341b07c3b8739575feacaad92d2460b89486b49f4eb49b80ce4a9de36a1152b48
76 changes: 76 additions & 0 deletions dev-php/composer/composer-2.0.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

DESCRIPTION="Dependency Manager for PHP"
HOMEPAGE="https://github.com/composer/composer"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="dev-lang/php:*[curl]
>=dev-php/ca-bundle-1.0
dev-php/fedora-autoloader
>=dev-php/jsonlint-1.4
>=dev-php/json-schema-5.2.10
>=dev-php/phar-utils-1.0
>=dev-php/psr-log-1.0
>=dev-php/reactphp-promise-2.7
>=dev-php/semver-3.0
>=dev-php/spdx-licenses-1.2
>=dev-php/symfony-console-2.8.52
>=dev-php/symfony-filesystem-2.8.52
>=dev-php/symfony-finder-2.8.52
>=dev-php/symfony-process-2.8.52
>=dev-php/xdebug-handler-1.1"

src_prepare() {
default

mkdir vendor || die

phpab \
--output vendor/autoload.php \
--template "${FILESDIR}"/autoload.php.tpl \
--basedir src \
src \
|| die

cat >> vendor/autoload.php <<EOF || die "failed to extend autoload.php"
// Dependencies
\Fedora\Autoloader\Dependencies::required([
'/usr/share/php/Composer/CaBundle/autoload.php',
'/usr/share/php/Composer/Semver/autoload.php',
'/usr/share/php/Composer/Spdx/autoload.php',
'/usr/share/php/Composer/XdebugHandler/autoload.php',
'/usr/share/php/JsonSchema/autoload.php',
'/usr/share/php/Psr/Log/autoload.php',
'/usr/share/php/Seld/JsonLint/autoload.php',
'/usr/share/php/Seld/PharUtils/autoload.php',
'/usr/share/php/Symfony/Component/Console/autoload.php',
'/usr/share/php/Symfony/Component/Filesystem/autoload.php',
'/usr/share/php/Symfony/Component/Finder/autoload.php',
'/usr/share/php/Symfony/Component/Process/autoload.php',
'/usr/share/php/React/Promise/autoload.php'
]);
EOF
}

src_install() {
insinto "/usr/share/${PN}"

# Composer expects the LICENSE file to be there, and the
# easiest thing to do is to give it what it wants.
doins -r LICENSE res src vendor

exeinto "/usr/share/${PN}/bin"
doexe "bin/${PN}"
dosym "../share/${PN}/bin/${PN}" "/usr/bin/${PN}"

dodoc CHANGELOG.md README.md doc/*.md
dodoc -r doc/articles doc/faqs
}
12 changes: 12 additions & 0 deletions dev-php/composer/files/autoload.php.tpl
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
<?php
// @codingStandardsIgnoreFile
// @codeCoverageIgnoreStart
require_once 'Fedora/Autoloader'.'/autoload.php';

\Fedora\Autoloader\Autoload::addClassMap(
array(
___CLASSLIST___,
),
__DIR__ . '/../src'
);
// @codeCoverageIgnoreEnd

0 comments on commit 110f7ca

Please sign in to comment.