Skip to content

Commit

Permalink
app-cdr/xfburn: Bump to 0.7.2
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Aug 13, 2024
1 parent 46dae5b commit 11299b1
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-cdr/xfburn/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST xfburn-0.7.1.tar.bz2 1250935 BLAKE2B 1b93b9ff89612e6a15c4990b6b0020e7353d46120a00da72ab9b1a6b30234a2baadfa9a1a2a074c5ebdbc5f140533ba21f5ef80fbdf0ebf4ba3c0a51f715a195 SHA512 ff5548655986a2dd4f21a0eebc971713c8ed463c8826899f37546af6255506c5b8b619c1667fd82eca6bc22355714bc7c3af269de071b3ce071dd6738207764a
DIST xfburn-0.7.2.tar.bz2 1305071 BLAKE2B 4b083ce28b2223b64e324908159181384ebc63cf891e9f847b316cf888b126a3dca727a94fde0130555324140d883a4a5e8a924990cdc3daa50c315bf3774193 SHA512 7966fc32a71b029f3e511565bcb751b06a9b87c2b434c9d546cccc1ba43479b1d1b17c9afe743babd08192e39907e4967e755a7b5fd72df3906645cce50db9a9
58 changes: 58 additions & 0 deletions app-cdr/xfburn/xfburn-0.7.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit xdg-utils

DESCRIPTION="GTK+ based CD and DVD burning application"
HOMEPAGE="
https://docs.xfce.org/apps/xfburn/start
https://gitlab.xfce.org/apps/xfburn/
"
SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
IUSE="gstreamer +udev"

DEPEND="
>=dev-libs/glib-2.38
>=dev-libs/libburn-0.4.2:=
>=dev-libs/libisofs-0.6.2:=
>=x11-libs/gtk+-3.20:3
>=xfce-base/exo-0.11.0:=
>=xfce-base/libxfce4ui-4.12.0:=
gstreamer? (
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
)
udev? ( dev-libs/libgudev:= )
"
RDEPEND="
${DEPEND}
"
BDEPEND="
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
"

src_configure() {
local myconf=(
$(use_enable udev gudev)
$(use_enable gstreamer)
)

econf "${myconf[@]}"
}

pkg_postinst() {
xdg_icon_cache_update
xdg_desktop_database_update
}

pkg_postrm() {
xdg_icon_cache_update
xdg_desktop_database_update
}

0 comments on commit 11299b1

Please sign in to comment.