forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Showing
2 changed files
with
46 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,5 @@ | ||
DIST metasploit-payloads-1.0.15.gem 5249536 SHA256 8d186c3bcf8a4537b9a96301e8cc0d847335d3cfa87ca5b2e88a6b2980eab240 SHA512 58afa5c4bc191a05e3ec009d94d40f2d9fc5a025962088845db14aefc410340fdc7b1e30f17c75936495a43fc99576d188960bc5755dbec434d7428fbbdd495a WHIRLPOOL d136642c1de9b18e652c421ad3b9fd859b8d8850dd539d66d4c8b410e09064d7872bc06c505b01d5389d1e2ebe22ed6b3c88aa3a0f08a1578f204201c24b3438 | ||
DIST metasploit-payloads-1.0.16.gem 11805696 SHA256 e127930c2b6cf09c91f2a2d7ef2a215aae2dee00172606c6b8644886b932301f SHA512 27f51db437f49d5685007e8a8762123890e6cce46b7465b2db3c070298e23bc4c440583c37da59b841a91deb100d47aa86db2d634f07ed212fbba11134c3fe47 WHIRLPOOL de81c9bbc1350621c8d3711fe29056a9116b7ffc63205f336d3efe22655777264c86790aec95d26af6858e516c0a667e368c021713ac87d8d20ff08b65e2bfd2 | ||
DIST metasploit-payloads-1.0.17.gem 11816448 SHA256 a7dbdbe04a0af1e4ff709ddd4d5eaef71ba9b11cdaafa7f599d6f1f6c9990740 SHA512 1158bad67ffcaa9e1664cd074e5a2db7a342a20faf687eb069ef0737e55c7b84ebe7cc3ed30fe0d6b113a039ecad0ba1102100d5d3e2cdce63dfbc6bb0277d93 WHIRLPOOL 5012027a4a8956a4c009798066d1166b149368715cb55259c465578df37cea53491b89ada67e452768252afd7ac48f275aafb2237a2f53e9093fd9a958314c7c | ||
DIST metasploit-payloads-1.0.19.gem 11816448 SHA256 ba5d9fa68f0efe13c52b20e2ce267099e788a446be2b275438910d666afc8633 SHA512 7551501619eb24ac38c7e8ecb4f037026ca360621f52d98703c3953cbfcd78192b6183c5c2cb3ae4b3a13484354b8652b9976ea2d9274278f9be23ac4f0aebd2 WHIRLPOOL 554fd259db13df063a884fce342275eb21b4d2843526e15de07e9466158606602fa83e3a9169ec06118f4b6a22013ebf522605708c48dcdf96648653bfbe0794 | ||
DIST metasploit-payloads-1.0.9.gem 5248000 SHA256 bd9eec335158dd25e579c680856f8c48aa9ba081a5d51d87a05dbb1e511087a3 SHA512 4c08284d4b1d667f545d97e879b2581830f34d42560ba6d6ed7adf32312adc841d5fdd8b55ab4e06a196d1e313fb44fbb861ccac7790e50f88260e2def0a76ed WHIRLPOOL a398dcad94b38626d4bd3d9980d05a24ccdbc12bbd2e902dd4f78c9bcd2cf4a26c76645d989a00aec69d041d9203c5ff31e0b0f948028ac6cd06ae724d573950 |
45 changes: 45 additions & 0 deletions
45
dev-ruby/metasploit-payloads/metasploit-payloads-1.0.19.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,45 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
USE_RUBY="ruby19 ruby20 ruby21 ruby22" | ||
|
||
RUBY_FAKEGEM_TASK_DOC="" | ||
|
||
RUBY_FAKEGEM_EXTRAINSTALL="data" | ||
|
||
inherit ruby-fakegem | ||
|
||
DESCRIPTION="Compiled binaries for Metasploit's Meterpreter" | ||
HOMEPAGE="https://rubygems.org/gems/metasploit-payloads" | ||
|
||
LICENSE="BSD" | ||
|
||
SLOT="${PV}" | ||
KEYWORDS="~amd64 ~arm ~x86" | ||
IUSE="" | ||
|
||
#no tests | ||
RESTRICT="test strip" | ||
|
||
QA_PREBUILT=" | ||
usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/msflinker_linux_x86.bin | ||
usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/ext_server_sniffer.lso | ||
usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/ext_server_networkpug.lso | ||
usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/ext_server_stdapi.lso | ||
usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs/armeabi/libndkstager.so | ||
usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs/mips/libndkstager.so | ||
usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs/x86/libndkstager.so | ||
" | ||
|
||
src_install() { | ||
ruby-ng_src_install | ||
#tell revdep-rebuild to ignore binaries meant for the target | ||
dodir /etc/revdep-rebuild | ||
cat <<-EOF > "${ED}"/etc/revdep-rebuild/99-${PN}-${SLOT} || die | ||
#These dirs contain prebuilt binaries for running on the TARGET not the HOST | ||
SEARCH_DIRS_MASK="/usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs" | ||
EOF | ||
} |