Skip to content

Commit

Permalink
app-misc/geneweb: EAPI 7 & use GLEP81
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <[email protected]>
  • Loading branch information
atupone committed Jan 1, 2020
1 parent 2119345 commit 1169c46
Showing 1 changed file with 77 additions and 0 deletions.
77 changes: 77 additions & 0 deletions app-misc/geneweb/geneweb-6.08-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,77 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit eutils

DESCRIPTION="Genealogy software program with a Web interface"
HOMEPAGE="https://github.com/geneanet/geneweb"
SRC_URI="https://github.com/geneweb/geneweb/archive/v6.08.tar.gz -> ${P}.tar.gz
https://dev.gentoo.org/~tupone/${P}-ocaml-4.patch.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+ocamlopt"
RESTRICT="strip"

RDEPEND="dev-lang/ocaml[ocamlopt?]
dev-ml/camlp5[ocamlopt?]
acct-user/geneweb
acct-group/geneweb"
DEPEND="${RDEPEND}"

PATCHES=(
"${WORKDIR}"/${P}-ocaml-4.patch
"${FILESDIR}"/${PF}-gentoo.patch
"${FILESDIR}"/${P}-parallellbuild.patch )

src_compile() {
if use ocamlopt; then
emake
else
emake OCAMLC=ocamlc OCAMLOPT=ocamlopt out
# If using bytecode we dont want to strip the binary as it would remove
# the bytecode and only leave ocamlrun...
fi
}

src_install() {
dodoc ICHANGES
emake new_distrib
emake wrappers
# Install doc
cd distribution
dodoc CHANGES.txt
# Install binaries
cd gw
dobin gwc gwc1 gwc2 consang gwd gwu update_nldb ged2gwb ged2gwb2 gwb2ged gwsetup
insinto /usr/lib/${PN}
doins -r gwtp_tmp/*
dodoc a.gwf
insinto /usr/share/${PN}
doins -r etc images lang setup gwd.arg only.txt

cd ../..

# Install binaries
dobin src/check_base
# Install manpages
doman man/*

# Install doc
dodoc -r contrib
docompress -x /usr/share/doc/${PF}/contrib

newinitd "${FILESDIR}/geneweb.initd" geneweb
newconfd "${FILESDIR}/geneweb.confd" geneweb
}

pkg_postinst() {
einfo "A CGI program has been installed in /usr/lib/${PN}. Follow the"
einfo "instructions on the README in that directory to use it"
einfo "For 64 bits architecture you need to rebuild the database"
einfo "\"gwu foo > foo.gw \" will save the database (use the previous"
einfo "version to do that). \"gwc2 foo.gw -o bar \" will restore it "
einfo "(using the current package)"
}

0 comments on commit 1169c46

Please sign in to comment.