Skip to content

Commit

Permalink
dev-ruby/rack-attack: add 6.5.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.13, Repoman-3.0.2
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Feb 9, 2021
1 parent da966c0 commit 11d5fea
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/rack-attack/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST rack-attack-6.3.1.gem 25088 BLAKE2B 97a6f36ad3571508f68b33090644db8fb21f6eb43f8ae16b0107dd3e0e1b8b728b6eaa43959dfa8b9781672147673b750c215c9ed01366de90175ba063d5d2b5 SHA512 e6c3fbc5a09cc3d15d06b450baf911b84dd412de7b1a9d0f67661da2106d1474ea2f7c2ec6a7cf5bbd9756642be519e618134c5c7888c41f44270afc4f8aff4a
DIST rack-attack-6.4.0.gem 25088 BLAKE2B 97f54f8d411d279731bf85ea5c43b875bdfe8f9eb32991b5c10b65cc6fd747b6b518b47da29bfccff9a037c9295f2c09b7b0c721bd24d42eaf0bda1012fc56b1 SHA512 f7d86521b65ecc92544c0f0d0af01e1de2e95d1087c732bd2e2c6aa944835bb5618bb35ca4bc60c42061627b5e8b5b030701238f42d61cd851d6b21ddb709e36
DIST rack-attack-6.5.0.gem 25600 BLAKE2B a2b40e3779b51f10d43da7381cf3aa6b83bf3ffcff26cde0cad47838bb7d4f3a255d2e182f3f56118afc29d8a487c574a79f2ec1d331ff51a746c5730888465a SHA512 3a50518972bbd4f9f5a2f4f5cc48958bae1d0636923e0124b34792d6f8ed10d435c9bdff64a31c79639667a996386f573c45214b931a3310d6749316db7ca37e
40 changes: 40 additions & 0 deletions dev-ruby/rack-attack/rack-attack-6.5.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
USE_RUBY="ruby25 ruby26 ruby27"

# Skip integration tests since they require additional unpackaged
# dependencies and running daemons.
RUBY_FAKEGEM_TASK_TEST="test:units"

RUBY_FAKEGEM_EXTRADOC="README.md"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem

DESCRIPTION="A DSL for blocking & throttling abusive clients"
HOMEPAGE="https://github.com/kickstarter/rack-attack"

LICENSE="MIT"
SLOT="$(ver_cut 1)"
KEYWORDS="~amd64"
IUSE="test"

ruby_add_rdepend "dev-ruby/rack:*"
ruby_add_bdepend "test? (
dev-ruby/actionpack
dev-ruby/activesupport
dev-ruby/railties
dev-ruby/rack-test
dev-ruby/minitest )"

all_ruby_prepare() {
sed -i -e '/\(bundler\|byebug\)/ s:^:#:' Rakefile spec/spec_helper.rb || die
sed -i -e '3igem "actionpack"' spec/spec_helper.rb || die
sed -i -e '/rubocop/I s:^:#:' Rakefile || die

# Avoid specs requiring a live redis service
sed -i -e '/should delete rack attack key/askip "requires redis service"' spec/rack_attack_spec.rb || die
}

0 comments on commit 11d5fea

Please sign in to comment.