Skip to content

Commit

Permalink
net-print/hplip-plugin: Version bump to 3.16.9
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.1
  • Loading branch information
mrueg committed Oct 10, 2016
1 parent 2e29b3f commit 11d9829
Show file tree
Hide file tree
Showing 2 changed files with 70 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-print/hplip-plugin/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST hplip-3.14.10-plugin.run 1869038 SHA256 b395b480ad86b9f27b6a2f63b6ecb00beb78e762a6137efb81dc1104837f9b81 SHA512 3e5bea924e989d902aea0de182941be692a124ba8c27f53ce2e4f137308bad8373462c6128c26716e481e758f76533163d311a2676df034c1b15d6ef6ed008be WHIRLPOOL 18375de4cc92cb73bcaa109927bd34f8487938b02472f0b7adbf44ad4688e5c6a1d030077b1e3c14f15f9b8e4cc86d195b0195e2d08121f746c62624db4658db
DIST hplip-3.16.3-plugin.run 2084271 SHA256 b7edef2a1c5c0a5e001deb4a18c0ef7202e653596e97144b8908ae093818070f SHA512 2ae8aeb40c2604a2c6b9725700f9addf7a82e819d603631158a5d5feac931248e53e7533178100df1fc12b0dc2340cb3ae0d85f145cd023a311f77bbe67e7c7f WHIRLPOOL 928117f862030eca9c3e5813eb8c4db66570923695b0c7af17df1992f339d2478f42af67ca0e0eb8cfa1d7425b522082fde3b8c829c3f5167e1ec503c95a986b
DIST hplip-3.16.8-plugin.run 2087862 SHA256 dd0b67fc1958bcf30c7ec7cb013d36d8071db6f78cc531e2169d139ba29117eb SHA512 f7ca720f343aef9b0d2fd4b3ded909c63fd6d7abce10060d5854b73c63d4a7c4e50c38da55728a53103dddac651068a242e07ae54be84b0ff6cb61fadba35245 WHIRLPOOL 5da94f21d59b51dcec1241046d1f9b7e4a44a8a9d56a4d5d615d2b117487556e67749c72a7d33e81536c0e25652614f88c0c8c6a8a65dcc45a6feac6da03293e
DIST hplip-3.16.9-plugin.run 2084344 SHA256 7394ab79dd943bb530a7117266dec3f280ac0f825c4d12831c14eec922349c9f SHA512 fdf6fd5d2ff458a5c68bce039914c72d1b118dd8909ef0333861ac26472801185bea43947b983fe164b1a1f80e99800fe3e098e045a0d3c7cbebd03ab83bcbe0 WHIRLPOOL a20d5c582b817eeb1900f6e2b1d650ff63b6eb6f08c4088fc462b66bfeafcbaa4122560fda87cdd0b85d7577a092abd2213c0606d91523306f6ad6349000bc58
69 changes: 69 additions & 0 deletions net-print/hplip-plugin/hplip-plugin-3.16.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,69 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="6"

inherit udev unpacker

DESCRIPTION="Proprietary plugins and firmware for HPLIP"
HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
SRC_URI="http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-${PV}-plugin.run"

LICENSE="hplip-plugin"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="
~net-print/hplip-${PV}
virtual/udev
"
DEPEND=""

S=${WORKDIR}

HPLIP_HOME=/usr/share/hplip

# Binary prebuilt package
QA_PRESTRIPPED="
/usr/share/hplip/fax/plugins/fax_marvell.so
/usr/share/hplip/prnt/plugins/hbpl1.so
/usr/share/hplip/prnt/plugins/lj.so
/usr/share/hplip/scan/plugins/bb_marvell.so
/usr/share/hplip/scan/plugins/bb_soapht.so
/usr/share/hplip/scan/plugins/bb_soap.so
"

# License does not allow us to redistribute the "source" package
RESTRICT="mirror"

src_unpack() {
unpack_makeself "hplip-${PV}-plugin.run"
}

src_install() {
local hplip_arch=$(use amd64 && echo 'x86_64' || echo 'x86_32')

insinto "${HPLIP_HOME}"/data/firmware
doins *.fw.gz

for plugin in *-${hplip_arch}.so; do
local plugin_type=prnt
case "${plugin}" in
fax_*) plugin_type=fax ;;
bb_*) plugin_type=scan ;;
esac

exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
newexe ${plugin} ${plugin/-${hplip_arch}}
done

mkdir -p "${ED}/var/lib/hp/"
cat >> "${ED}/var/lib/hp/hplip.state" <<-_EOF_
[plugin]
installed = 1
eula = 1
version = ${PV}
_EOF_
}

0 comments on commit 11d9829

Please sign in to comment.