forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-action/geki3-KXL: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.2.28
- Loading branch information
Showing
2 changed files
with
61 additions
and
8 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,53 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
inherit autotools eutils user | ||
|
||
DESCRIPTION="2D length scroll shooting game" | ||
HOMEPAGE="http://triring.net/ps2linux/games/kxl/kxlgames.html" | ||
SRC_URI="mirror://gentoo/${P}.tar.gz | ||
mirror://gentoo/${PN}.png" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND="dev-games/KXL" | ||
RDEPEND="${DEPEND} | ||
media-fonts/font-adobe-100dpi" | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/${P}-paths.patch | ||
) | ||
|
||
pkg_setup(){ | ||
enewgroup gamestat 36 | ||
} | ||
|
||
src_prepare() { | ||
default | ||
rm -f missing | ||
sed -i \ | ||
-e '1i #include <string.h>' \ | ||
-e "s:DATA_PATH \"/.score\":\"/var/games/${PN}\":" \ | ||
src/ranking.c || die | ||
sed -i -e '/CFLAGS/s/$/ @CFLAGS@/' src/Makefile.am || die #bug 426890 | ||
mv configure.{in,ac} | ||
eautoreconf | ||
} | ||
|
||
src_install() { | ||
default | ||
|
||
insinto /var/games/${PN} | ||
newins data/.score ${PN} | ||
fowners root:gamestat /var/games/${PN} /usr/bin/geki3 | ||
fperms 660 /var/games/${PN} | ||
fperms 2755 /usr/bin/geki3 | ||
|
||
doicon "${DISTDIR}"/${PN}.png | ||
make_desktop_entry geki3 Geki3 | ||
} |