Skip to content

Commit

Permalink
app-emulation/spice-vdagent: version bump to 0.21.0
Browse files Browse the repository at this point in the history
Fixes for
  CVE-2020-25650
  CVE-2020-25651
  CVE-2020-25652
  CVE-2020-25653

Bug: https://bugs.gentoo.org/753956
Package-Manager: Portage-3.0.18, Repoman-3.0.3
Signed-off-by: Matthias Maier <[email protected]>
  • Loading branch information
tamiko committed Apr 4, 2021
1 parent c801e35 commit 1201373
Show file tree
Hide file tree
Showing 2 changed files with 63 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/spice-vdagent/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST spice-vdagent-0.19.0.tar.bz2 151356 BLAKE2B b7a99a7205d955b27edfe483746e3f267a6e0b7885c4b8146ba42d99b581cf4e1748b503a37a3d6b66623ef2515b42756f2e6a5a4775d56def7aa396bd0dfb4f SHA512 f5056dfe66df3ee8205549be22bbc8c17d2196c8448eda97f01659ff30c34d9929f330767d7fafec557dc5f7fb9b65eaf85973193b38df774042de9b72d6e60d
DIST spice-vdagent-0.20.0.tar.bz2 152510 BLAKE2B b00caadab385f4208bd18b78a006831953f99387e55fd86226efffdf537426627f02bb46708173b700eecd21f598a0db94f454c5252b0f4bfb93c30b39d69d16 SHA512 a6288e056645c071834f9ce5800669cb64e0f86a5efeb8eec61ac1e11f1fd56f7da8ea19b28a94c88741d794a0290fac9bcf74d45bcef271c2c5abfb2573a8e1
DIST spice-vdagent-0.21.0.tar.bz2 164103 BLAKE2B 298122b334f880ffb8d77d3a7d822b70debce56d62bc3004bbac37445f10236a47706d23501ee3f82520c45b65deec12c9578cf4a8b9ac138df8b1c0b8cdb784 SHA512 1ff1a89e75301b1c2c89f26ba4bce8d4df29bbff6387ade128ce847ca30162a2bc731c70c10a8d129518e64bbca6b8271fd11ff3e340899182a65a5295051bff
62 changes: 62 additions & 0 deletions app-emulation/spice-vdagent/spice-vdagent-0.21.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools linux-info

DESCRIPTION="SPICE VD Linux Guest Agent"
HOMEPAGE="https://www.spice-space.org/"
SRC_URI="https://www.spice-space.org/download/releases/${P}.tar.bz2"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gtk selinux systemd"

CDEPEND="
dev-libs/glib:2
>=app-emulation/spice-protocol-0.14.0
media-libs/alsa-lib
>=x11-libs/libpciaccess-0.10
x11-libs/libdrm
x11-libs/libXfixes
x11-libs/libXrandr
x11-libs/libX11
x11-libs/libXinerama
gtk? ( x11-libs/gtk+:3 )
systemd? ( sys-apps/systemd )"
DEPEND="${CDEPEND}
virtual/pkgconfig"
RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-vdagent )"

CONFIG_CHECK="~INPUT_UINPUT ~VIRTIO_CONSOLE"
ERROR_INPUT_UINPUT="User level input support (INPUT_UINPUT) is required"
ERROR_VIRTIO_CONSOLE="VirtIO console/serial device support (VIRTIO_CONSOLE) is required"

src_configure() {
local opt=()
if use systemd; then
opt+=( --with-session-info=systemd )
else
opt+=( --with-session-info=none )
fi

econf \
--with-init-script=systemd \
--localstatedir="${EPREFIX}"/var \
$(use_with gtk) \
"${opt[@]}"
}

src_install() {
default

cd "${ED}" && rmdir -p var/run/spice-vdagentd || die

keepdir /var/log/spice-vdagentd

newinitd "${FILESDIR}/${PN}.initd-4" "${PN}"
newconfd "${FILESDIR}/${PN}.confd-2" "${PN}"
}

0 comments on commit 1201373

Please sign in to comment.