Skip to content

Commit

Permalink
app-vim/vimclojure: version bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
monsieurp committed May 29, 2017
1 parent 6b69451 commit 121d5f9
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-vim/vimclojure/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST 2.3.6.zip 44737 SHA256 7c1a9197e8ed2540c921a4e448c88d784740de891cfe58c57e19e9c5c499cd5b SHA512 daf4f691500c3b901a57849c6f07b500c49f7086e0733921f589e362a53a0d07b99eab7d6ea42f1828822942b294f51a684eec93ebab1797438da4b81199ca9d WHIRLPOOL b908cf86313cdd3521f15c2090cbb9f4f2a8a7c656ff1a152fa3707f62e1c6a49fbf6dcf2d596107e6cb2ab579f9aa3e5aec60d04fc91a8f08396bb813b43481
DIST vimclojure-2.3.6.zip 44737 SHA256 7c1a9197e8ed2540c921a4e448c88d784740de891cfe58c57e19e9c5c499cd5b SHA512 daf4f691500c3b901a57849c6f07b500c49f7086e0733921f589e362a53a0d07b99eab7d6ea42f1828822942b294f51a684eec93ebab1797438da4b81199ca9d WHIRLPOOL b908cf86313cdd3521f15c2090cbb9f4f2a8a7c656ff1a152fa3707f62e1c6a49fbf6dcf2d596107e6cb2ab579f9aa3e5aec60d04fc91a8f08396bb813b43481
52 changes: 52 additions & 0 deletions app-vim/vimclojure/vimclojure-2.3.6-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit vim-plugin

MY_PN="VimClojure"

DESCRIPTION="vim plugin: Clojure syntax highlighting, filetype and indent settings"
HOMEPAGE="https://github.com/vim-scripts/VimClojure"
SRC_URI="https://github.com/vim-scripts/${MY_PN}/archive/${PV}.zip -> ${P}.zip"

KEYWORDS="~amd64 ~x86"
LICENSE="BSD"
SLOT="0"

RDEPEND="dev-lang/clojure"

S="${WORKDIR}/${MY_PN}-${PV}"

DOCS=( doc/LICENSE.txt )

# Files with similar names are already installed by app-vim/slimv.
DUPLICATE_FILES=(
indent/clojure.vim
ftdetect/clojure.vim
)

src_prepare() {
default

# Remove .bat files.
find . -type f -name \*.bat -exec rm -v {} \; || die

# Let's simply rename ${DUPLICATE_FILES[@]}.
local f
for f in "${DUPLICATE_FILES[@]}"; do
[[ -f "${f}" ]] || die "Couldn't find ${f}"
bname="${f##*/}"
path="${f%/*}"
noext="${bname%%.*}"
newname="${path}/${PN}_${noext}.vim"
mv -v "${f}" "${newname}" || die
done
}

src_install() {
einstalldocs
rm -rv "${DOCS[@]}" bin || die
vim-plugin_src_install
}

0 comments on commit 121d5f9

Please sign in to comment.