Skip to content

Commit

Permalink
dev-util/bcc: version bump to 0.5.0_p20171230
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/642852
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
zmedico committed Jan 2, 2018
1 parent 86f1819 commit 12418e7
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/bcc/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST bcc-0.5.0.tar.gz 1764775 BLAKE2B e1e059b83846115347f225e968edd2823408c26f4f25a89e26c663147ca9c379222c4f1d97578f7cf981fbbb23307deab408bcb278cb26fde5399afbbceb1e39 SHA512 12de5ef04185dccd0847fc97ae855b386e0c81b545ae497af797667925ebedf97164c17fb99468abae3f87fb3ddfdba5200070f80b3bbcad63c2355497012f0e
DIST bcc-0.5.0_p20171230.tar.gz 1773522 BLAKE2B bc5ec32570cf230f071c10d2925a8c8a777c60c22d31bbf72f3cad1718e59dacd604e45a326ff2a941aa519a2b3544bc7376dd40ceafe154c497b488e0ec1b9b SHA512 d8e810768b5801c0beef98a13ee23eb8aa756f7f8a3e35f6a391958e30affc5a8622a9b75c785f66d86761105045cb2b1c7ce284f3ac3b482a4605987bea9f30
51 changes: 51 additions & 0 deletions dev-util/bcc/bcc-0.5.0_p20171230.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5,6} )

inherit cmake-utils linux-info python-single-r1 python-utils-r1

DESCRIPTION="Tools for BPF-based Linux IO analysis, networking, monitoring, and more"
HOMEPAGE="https://iovisor.github.io/bcc/"
EGIT_COMMIT="82ef5a0d999b687d26059e5adfdaac3e605f2339"
SRC_URI="https://github.com/iovisor/bcc/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
RESTRICT="test"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND=">=dev-libs/elfutils-0.166:=
sys-devel/clang:=
>=sys-devel/llvm-3.7:=[llvm_targets_BPF(+)]
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
S=${WORKDIR}/${PN}-${EGIT_COMMIT#v}

pkg_pretend() {
local CONFIG_CHECK="~BPF ~BPF_SYSCALL ~NET_CLS_BPF ~NET_ACT_BPF
~BPF_JIT ~BPF_EVENTS"

check_extra_config
}

pkg_setup() {
python-single-r1_pkg_setup
}

src_configure() {
local mycmakeargs=(
-DREVISION=${PV%%_*}
)

cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install
python_fix_shebang "${ED}"
}

0 comments on commit 12418e7

Please sign in to comment.