Skip to content

Commit

Permalink
app-crypt/acme-tiny: Bump to 4.0.3
Browse files Browse the repository at this point in the history
--account-email flag changed to --contact, requires new syntax, so
make sure to update scripts accordingly

Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
NP-Hardass committed Mar 27, 2018
1 parent d055348 commit 1248149
Show file tree
Hide file tree
Showing 3 changed files with 63 additions and 9 deletions.
1 change: 1 addition & 0 deletions app-crypt/acme-tiny/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST acme-tiny-0_p20170917.tar.gz 10516 BLAKE2B e9d4ae170579cd5379dbb4d900d051bc1789ac994eb491aafb9952cd004b3e3feed20ef505f88587035f3f16163e7965a1b3883caaaa8c2327fca6be0240a17f SHA512 0bfb0d064f21f9d89e3c5863f33c7326c02948a42e2c8dc11c7b5baaf5e0dfcaeba0ad461b2ad12e292cc14f64b44f331f11b56dda6592a4663baf0714048700
DIST acme-tiny-4.0.0.tar.gz 11934 BLAKE2B 2303fcd4e14d75cb7b36426f9ffe7e5f989d886be16b322aea2f8b40937e8c1a850704869570911ff7365a9545f5e41006f4e655ba207db9a7105ec3d59c8c32 SHA512 45f3469fbfa8b57c5755595823a6d08fd977c29d948b618ab6bd9c4feba4910bdcc1540757ba78bcdcd7e01c6f7451f4e8aec951a0ae118ab6597a1714f30691
DIST acme-tiny-4.0.3.tar.gz 12662 BLAKE2B 6a17d0597731a5c8c1b260fa47396cb5bf8a223f44c8e498532b6e90a2ded35c5fcae058a8682e59ab060c1eeb27e09c8db8588e1d72cfd75b65f867d3e94f9a SHA512 bd37d4f878f2851c8e88acb78699b855cfd306928e2d70ef1d35dc9883d44dae3c7622e2114b1d5c4e0c5865b61ad3958a776467ab45eaedb0cf612530ca5dc7
48 changes: 48 additions & 0 deletions app-crypt/acme-tiny/acme-tiny-4.0.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
inherit distutils-r1 eapi7-ver

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/diafygi/${PN}.git"
KEYWORDS=""
else
SRC_URI="https://github.com/diafygi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="A tiny, auditable script for Let's Encrypt's ACME Protocol"
HOMEPAGE="https://github.com/diafygi/acme-tiny"

LICENSE="MIT"
SLOT="0"
IUSE=""

DEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
RDEPEND="dev-libs/openssl:0"

pkg_setup() {
if [[ ${PV} != 9999 ]]; then
export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
fi
}

src_prepare() {
sed -i 's|#!/usr/bin/sh|#!/bin/sh|g' README.md || die

distutils-r1_src_prepare
}

pkg_postinst() {
for v in ${REPLACING_VERSIONS}; do
if ver_test "$v" "-lt" "4.0.3" || ver_test "$v" "-ge" "9999"; then
einfo "The --account-email flag has been changed to --contact and"
einfo "has different syntax."
einfo "Please update your scripts accordingly"
fi
done
}
23 changes: 14 additions & 9 deletions app-crypt/acme-tiny/acme-tiny-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@
EAPI=6

PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
inherit distutils-r1
inherit distutils-r1 eapi7-ver

if [[ ${PV} == 9999 ]]; then
inherit git-r3
Expand All @@ -20,8 +20,7 @@ HOMEPAGE="https://github.com/diafygi/acme-tiny"

LICENSE="MIT"
SLOT="0"

IUSE="minimal"
IUSE=""

DEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
RDEPEND="dev-libs/openssl:0"
Expand All @@ -33,11 +32,17 @@ pkg_setup() {
}

src_prepare() {
if ! use minimal; then
local PATCHES=(
"${FILESDIR}/${PN}-PR87-readmefix.patch"
"${FILESDIR}/${PN}-4.0.0-PR101-contactinfo.patch"
)
fi
sed -i 's|#!/usr/bin/sh|#!/bin/sh|g' README.md || die

distutils-r1_src_prepare
}

pkg_postinst() {
for v in ${REPLACING_VERSIONS}; do
if ver_test "$v" "-lt" "4.0.3" || ver_test "$v" "-ge" "9999"; then
einfo "The --account-email flag has been changed to --contact and"
einfo "has different syntax."
einfo "Please update your scripts accordingly"
fi
done
}

0 comments on commit 1248149

Please sign in to comment.