Skip to content

Commit

Permalink
dev-embedded/cpik: 0.7.4_p4 version bump, use qtcore:5, fix GCC-6
Browse files Browse the repository at this point in the history
Thanks-to: Thomas Posch <[email protected]>
Bug: https://bugs.gentoo.org/644402
Closes: https://bugs.gentoo.org/639554
Package-Manager: Portage-2.3.28, Repoman-2.3.9
  • Loading branch information
a17r committed Apr 8, 2018
1 parent 89207d1 commit 1257a57
Show file tree
Hide file tree
Showing 3 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-embedded/cpik/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cpik-0.7.2-4.tar.gz 5960822 BLAKE2B 744c3a35bb5c2421b14497e2f34c1a5bb37ba7a69d918ff72353970b1d973b4ac8443ab0fff61676100c9489a7bfef6c907932b77d67a1681bf4ed532c0b4cf9 SHA512 e1ea5ebdd8eb2481dbfebb14c6e194d277755fbbd58388c089d0127006485a3a8b66b79e58135903ea41d4f7b1ccc49263519b741e680f29c0aa486240b12df3
DIST cpik-0.7.4-4.tar.gz 8322003 BLAKE2B e88f04a92f44800139089b3115da42c5bbe88128300db28660b9300ae4260cba08432de0865d0426ce179743388483c9a3310c417bfaa3c7e4ef93217c38574b SHA512 d376af949bd2fbc80bd3c13e02d44c5a9ef82c409ac20e4c750fa77b654b89e77289b5a022988e05261cdbfe15563f837ec0e6382bb8bf27be673d0e55bbfa2c
46 changes: 46 additions & 0 deletions dev-embedded/cpik/cpik-0.7.4_p4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit qmake-utils

MY_PV="${PV/_p/-}"
MY_P="${PN}-${MY_PV}"

DESCRIPTION="C compiler for PIC18 devices"
HOMEPAGE="http://pikdev.free.fr/"
SRC_URI="http://pikdev.free.fr/${MY_P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="dev-qt/qtcore:5"
RDEPEND=""

S="${WORKDIR}/${MY_P}"

DOCS=( ${MY_PV/-*/}/doc/cpik-{0.5.2-tutorial,0.7.4-4-doc}.pdf )
HTML_DOCS=( ${MY_PV/-*/}/doc/html/. )

PATCHES=( "${FILESDIR}/${P}-gcc6.patch" )

src_prepare() {
default

# does not install docs in wrong path
sed -e '/INSTALLS += docs/d' \
-i "${PN}"*.pro || die 'sed failed.'
}

src_configure() {
eqmake5
}

src_install() {
emake INSTALL_ROOT="${D}" install
einstalldocs
dosym "${PN}-${MY_PV/-*/}" "/usr/bin/${PN}"
}
12 changes: 12 additions & 0 deletions dev-embedded/cpik/files/cpik-0.7.4_p4-gcc6.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
diff -Naur cpik-0.7.2-4-orig/utility.h cpik-0.7.2-4/utility.h
--- cpik-0.7.2-4-orig/utility.h 2017-12-03 03:47:35.302504007 +0100
+++ cpik-0.7.2-4/utility.h 2017-12-03 03:47:59.537116442 +0100
@@ -75,7 +75,7 @@
static bool stringTo ( const string& s, T& result )
{
istringstream is ( s ) ;
- return is >> result ;
+ return static_cast<bool>(is >> result);
}

/** generic conversion from T to string */

0 comments on commit 1257a57

Please sign in to comment.