forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Alexis Ballier <[email protected]>
- Loading branch information
Showing
2 changed files
with
38 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST urdfdom-1.0.0.tar.gz 250016 BLAKE2B 525616785b4fa38c8900add42349aa3a2103c75b213c77e3d682084e674b5fae31e9f56331910c19e6e5c49f6f72e1e7240c588df0dc67d862e0eac911667381 SHA512 50a218e596bcc0cecff904db2fa626bebc3902c4fe1f5ff8e08195e462b4d9a8c416a41f4773cabbcc71490060d3feff7e8528a76b824569dc7fdb0bda01ec3f | ||
DIST urdfdom-1.0.3.tar.gz 275339 BLAKE2B aa14dbd5f55489e0bde97042afb03d47cd023e3003a4ff66808e9be1a03c4de0bdab1c56a6fb5f6aea83324cbb38d286def66553a8ef813fc1f70b0bd9e24268 SHA512 240181d9c61dd7544f16a79a400d9a2c4dc0a682bef165b46529efcb4b31e2a34e27896933b60b9ddbaa5c4a8d575ebda42752599ff3b0a98d1eeef8f9b0b7a7 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,37 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=5 | ||
|
||
SCM="" | ||
if [ "${PV#9999}" != "${PV}" ] ; then | ||
SCM="git-r3" | ||
EGIT_REPO_URI="https://github.com/ros/urdfdom" | ||
fi | ||
|
||
inherit ${SCM} cmake-utils | ||
|
||
if [ "${PV#9999}" != "${PV}" ] ; then | ||
KEYWORDS="" | ||
SRC_URI="" | ||
else | ||
KEYWORDS="~amd64 ~arm" | ||
SRC_URI="https://github.com/ros/urdfdom/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
fi | ||
|
||
DESCRIPTION="URDF (U-Robot Description Format) library" | ||
HOMEPAGE="http://ros.org/wiki/urdf" | ||
LICENSE="BSD" | ||
SLOT="0/1" | ||
IUSE="" | ||
|
||
RDEPEND=">=dev-libs/urdfdom_headers-1.0.0 | ||
>=dev-libs/console_bridge-0.3:= | ||
dev-libs/tinyxml | ||
dev-libs/boost:=[threads]" | ||
DEPEND="${RDEPEND}" | ||
|
||
src_prepare() { | ||
sed -i -e 's/set(CMAKE_INSTALL_LIBDIR/#/' CMakeLists.txt || die | ||
cmake-utils_src_prepare | ||
} |