Skip to content

Commit

Permalink
app-crypt/qca: 2.3.1 version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Jul 6, 2020
1 parent 89a30b5 commit 1262f70
Show file tree
Hide file tree
Showing 2 changed files with 85 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-crypt/qca/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST qca-2.3.0.tar.xz 729504 BLAKE2B 71cf9dfae00066c14e1055da1fa1a8e1210f538b1addfde1b99a9b26b1e8f7dd61e289d0f505b5ec04d5f4745216d4fd0f8be8f8de9e9cbf74123907ba703d0e SHA512 ca9251868e073834562fa62ffc64b3e7817c9ddadc6bc3fb99cf8b5c8d859969562170a98874be9590c617b2dd8e5590d2c83792554f54bb880c677902db22fe
DIST qca-2.3.1.tar.xz 725984 BLAKE2B a99121dd95822ef5e1057dc9ad9250bb14486f42b0571936453644bc7c5649f16cbc918fa04d4a5af2c62bc35cc672159a84e27a86e685cfe320518a42076052 SHA512 092704a8d7c5973f05c82584ea55b4f8f874965aea943277e50fde873913a9bdad6a51ea74fc0036bbb632a13141cb4c030504229c06779890286205929f6021
84 changes: 84 additions & 0 deletions app-crypt/qca/qca-2.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,84 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit kde.org cmake qmake-utils

DESCRIPTION="Qt Cryptographic Architecture (QCA)"
HOMEPAGE="https://userbase.kde.org/QCA"
SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"

LICENSE="LGPL-2.1"
SLOT="2"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
IUSE="botan debug doc examples gcrypt gpg logger nss pkcs11 sasl softstore +ssl test"

RESTRICT="!test? ( test )"

BDEPEND="
doc? ( app-doc/doxygen )
"
RDEPEND="
dev-qt/qtcore:5
botan? ( dev-libs/botan:= )
gcrypt? ( dev-libs/libgcrypt:= )
gpg? ( app-crypt/gnupg )
nss? ( dev-libs/nss )
pkcs11? (
>=dev-libs/openssl-1.1
dev-libs/pkcs11-helper
)
sasl? ( dev-libs/cyrus-sasl:2 )
ssl? ( >=dev-libs/openssl-1.1:0= )
"
DEPEND="${RDEPEND}
test? (
dev-qt/qtnetwork:5
dev-qt/qttest:5
)
"

PATCHES=( "${FILESDIR}/${PN}-disable-pgp-test.patch" )

qca_plugin_use() {
echo -DWITH_${2:-$1}_PLUGIN=$(usex "$1")
}

src_configure() {
local mycmakeargs=(
-DQCA_FEATURE_INSTALL_DIR="${EPREFIX}$(qt5_get_mkspecsdir)/features"
-DQCA_PLUGINS_INSTALL_DIR="${EPREFIX}$(qt5_get_plugindir)"
$(qca_plugin_use botan)
$(qca_plugin_use gcrypt)
$(qca_plugin_use gpg gnupg)
$(qca_plugin_use logger)
$(qca_plugin_use nss)
$(qca_plugin_use pkcs11)
$(qca_plugin_use sasl cyrus-sasl)
$(qca_plugin_use softstore)
$(qca_plugin_use ssl ossl)
-DBUILD_TESTS=$(usex test)
)
cmake_src_configure
}

src_test() {
local -x QCA_PLUGIN_PATH="${BUILD_DIR}/lib/qca"
cmake_src_test
}

src_install() {
cmake_src_install

if use doc; then
pushd "${BUILD_DIR}" >/dev/null || die
doxygen Doxyfile || die
dodoc -r apidocs/html
popd >/dev/null || die
fi

if use examples; then
dodoc -r "${S}"/examples
fi
}

0 comments on commit 1262f70

Please sign in to comment.