Skip to content

Commit

Permalink
net-misc/miniupnpd: Bump to 2.0.20161216
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Jan 26, 2017
1 parent dccca91 commit 12b15ac
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/miniupnpd/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST miniupnpd-2.0.20161216.tar.gz 218119 SHA256 9e73d50ac830b5e08b6eb1df4e4c917833a5ab54351809f615d15d0f30cdeef3 SHA512 af82f060d28033dd670fcc96c8e2895f92d249a8a79d991e0215159eeb57715d7a9152d7d751b836091f7a623ce8a194ea243d1a2fb639349e320c02ce187c27 WHIRLPOOL 478a56b137b86ba1dca70e15c7dbdef2969a2d089e1ae0bac7ff01c18e753c8c3cca8b89ef415d54c3a009b89156eb507e97ba1949223bdd37914042c5124be1
DIST miniupnpd-2.0.tar.gz 217802 SHA256 d96aa3a00e0f5490826bba3cb97e68cd27479e5839adac4b9bcb66eae786bfb7 SHA512 c88036d3f4b065fc855572db8945d921641a71a23ffe8b52cb4ccb1a7cf3e7396841c436d54d7ff5968d034d8c4bfc91630719959000436230bb8c37e5bdc8d4 WHIRLPOOL d6aec880c9ef3c70002fdf9a98a0e8f4de95d8b3c9c6a18e328bc94d7dc3b8c130829c8ea6117e27e5b0aac1cd4526bbc9d9de21bd13e7b5527db54a656a1fff
63 changes: 63 additions & 0 deletions net-misc/miniupnpd/miniupnpd-2.0.20161216.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit toolchain-funcs

DESCRIPTION="MiniUPnP IGD Daemon"
HOMEPAGE="http://miniupnp.free.fr/"
SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="+leasefile igd2 ipv6 pcp-peer portinuse strict"

RDEPEND=">=net-firewall/iptables-1.4.6:0=[ipv6?]
net-libs/libnfnetlink:=
net-libs/libmnl:=
dev-libs/gmp:0=
sys-apps/util-linux
dev-libs/openssl:0="
DEPEND="${RDEPEND}
sys-apps/lsb-release"

src_prepare() {
default
mv Makefile.linux Makefile || die
}

src_configure() {
local -a opts
opts=(
--vendorcfg
$(use igd2 && printf -- '--igd2\n')
$(use ipv6 && printf -- '--ipv6\n')
$(use leasefile && printf -- '--leasefile\n')
$(use portinuse && printf -- '--portinuse\n')
$(use pcp-peer && printf -- '--pcp-peer\n')
$(use strict && printf -- '--strict\n')
)

emake CONFIG_OPTIONS="${opts[*]}" config.h
}

src_compile() {
# By default, it builds a bunch of unittests that are missing wrapper
# scripts in the tarball
emake CC="$(tc-getCC)" STRIP=true miniupnpd
}

src_install() {
emake PREFIX="${ED}" STRIP=true install

newinitd "${FILESDIR}"/${PN}-init.d-r1 ${PN}
newconfd "${FILESDIR}"/${PN}-conf.d-r1 ${PN}
}

pkg_postinst() {
elog "Please correct the external interface in the top of the two"
elog "scripts in /etc/miniupnpd and edit the config file in there too"
}

0 comments on commit 12b15ac

Please sign in to comment.