Skip to content

Commit

Permalink
app-misc/pdfpc: Version bump to 4.1.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.33, Repoman-2.3.9
  • Loading branch information
mrueg committed May 3, 2018
1 parent 65e3b18 commit 12f30b0
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/pdfpc/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST pdfpc-3.1.1.tgz 199004 BLAKE2B 4efaf84e13dd4b90e66365429e3f2aed498e8fab039660acb377b4b0331da9f43d446827d204fa64143af566e072666878dc3a3d3787aa6480cd658feff7eeec SHA512 554203094b18fe11fd085414961de6644df3c258ad52d46ad171cfd6c2199028bcbaa9560bdaba63d83f858b467407cc276972b34f341cc25260db1d1358e88d
DIST pdfpc-4.0.7.tar.gz 83626 BLAKE2B e64b36a9cc3f7c4745a0e8b40ae963fa58c99da19c5c839dc1934cbf2def4c7173780ae8108ae9d55e40df46b054f0a66f6d15e2c37d43e4e05bc4c71761eb33 SHA512 557e2a24e7aa4b0a7bc413517d6b274c7bad91f5e9d24ec139d0e62c490712081344448bfbedc82a90d28cd9b5910a6f51863aa44dc1c7a61ada6d154780444c
DIST pdfpc-4.0.8.tar.gz 91138 BLAKE2B 1160590fddff914ddfc8c5a25d83b9e680cd6ec9ebef8f3809c1de31629da2879dbddd766a65d31d86b8fd0ebc735f10a51eabb7c18e5d62e96f656810d8730d SHA512 f077f08f2ee997d55b4e4ced31ec6f21791353871104fff9ece264455a18e30ba365933b15b6b596817f3e6f3f0a181f4fecf19180b8a4337f3752d3aebec7d7
DIST pdfpc-4.1.1.tar.gz 96995 BLAKE2B f032cf0207cfb116ef98a171376d1cc80ae20f70eb7a63cf29dbd93e73c7bc1b0ef7638f9086d9908470d988830c4b420d9b96e7764af6219267d9ca6aad557a SHA512 51fa8e7743e02ba7e119dc86505f4513c174842a22d5755154775bd9abd945e7bcb9ba3c205cb27de25c38271762307136cb5370443131ea80cc0b9187e531bf
44 changes: 44 additions & 0 deletions app-misc/pdfpc/pdfpc-4.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

VALA_MIN_API_VERSION="0.26"
VALA_MAX_API_VERSION="0.36" # fix sed line if you increase this

inherit vala cmake-utils

DESCRIPTION="Presenter console with multi-monitor support for PDF files"
HOMEPAGE="http://pdfpc.github.io"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gstreamer"

RDEPEND="app-text/poppler[cairo]
dev-libs/glib:2
dev-libs/libgee:0.8
gnome-base/librsvg
gstreamer? ( media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0 )
sys-apps/dbus
x11-libs/gtk+:3"
DEPEND="${RDEPEND}
$(vala_depend)"

src_prepare() {
cmake-utils_src_prepare

sed -i -e "s/valac-0.20/valac-0.36 valac-0.34 valac-0.32 valac-0.30 valac-0.28 valac-0.26/" cmake/vala/FindVala.cmake || die
vala_src_prepare
}

src_configure(){
local mycmakeargs=(
-DSYSCONFDIR="${EPREFIX}/etc"
-DMOVIES=$(usex gstreamer on off)
)
cmake-utils_src_configure
}

0 comments on commit 12f30b0

Please sign in to comment.