Skip to content

Commit

Permalink
app-crypt/keybase: Update live ebuild
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
nicolasbock committed Feb 23, 2018
1 parent 580a0c9 commit 1303d32
Showing 1 changed file with 18 additions and 3 deletions.
21 changes: 18 additions & 3 deletions app-crypt/keybase/keybase-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils versionator git-r3
inherit eutils systemd user versionator git-r3

MY_PV=$(replace_version_separator 3 '-')

Expand All @@ -17,12 +17,17 @@ KEYWORDS=""
IUSE=""

DEPEND="
>=dev-lang/go-1.6:0"
>=dev-lang/go-1.6:0
app-crypt/kbfs"
RDEPEND="
app-crypt/gnupg"

S="${WORKDIR}/src/github.com/keybase/client"

pkg_setup() {
enewuser keybasehelper
}

src_unpack() {
git-r3_src_unpack
mkdir -p "$(dirname "${S}")" || die
Expand All @@ -35,13 +40,23 @@ src_compile() {
-tags production \
-o "${T}/keybase" \
github.com/keybase/client/go/keybase || die
GOPATH="${WORKDIR}" \
go build -v -x \
-tags production \
-o "${T}/keybase-mount-helper" \
github.com/keybase/client/go/mounter/keybase-mount-helper || die
}

src_install() {
dobin "${T}/keybase"
dobin "${T}/keybase-mount-helper"
fowners keybasehelper:keybasehelper "${EROOT}/usr/bin/keybase-mount-helper"
dobin "${S}/packaging/linux/run_keybase"
systemd_douserunit "${S}/packaging/linux/systemd/keybase.service"
}

pkg_postinst() {
elog "Run the service: keybase service"
elog "Run the client: keybase login"
elog "Restart keybase: run_keybase"
}

0 comments on commit 1303d32

Please sign in to comment.