Skip to content

Commit

Permalink
app-emacs/denote: add 3.0.8
Browse files Browse the repository at this point in the history
Also, remove RESTRICT="test" and only skip the failing test.

Signed-off-by: Matthew Smith <[email protected]>
  • Loading branch information
MatthewGentoo committed Aug 4, 2024
1 parent 9bdd082 commit 132aa54
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emacs/denote/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST denote-3.0.6.tar.gz 243081 BLAKE2B 7aebcc64b500853d9b34e687ae478b081d74f0ce688c3a0cdff55028a007cdf572f2b12ca6c687f9de1975ae24ce3933225390290ee892b127c7c0a4cb9cd707 SHA512 eabd61379b6621c573ac41e40f4ee6dbaf799aca49ccd011249492a035ae734ab86dcc33346593c1c77e7f250c129bc06f3cada9292c1541fd2ffd6d679ae59f
DIST denote-3.0.7.tar.gz 243763 BLAKE2B ed65226f77e50428cc35faccb0f51caa406f46de2aeeb9fddb6513912e68296a1edf41a7ea40f529bc15ec020118934d31cc2aeb905462b0fbe9295c56621c0f SHA512 ec8abb9b751c16abb4d48fc5d1531badba1e2d5a08534c2f31236fd86b03c89d68dcf05085aaa998724d09a809efef8ee580ddb58e043b256ad6040070c08f77
DIST denote-3.0.8.tar.gz 244541 BLAKE2B bbabd44e0a4f1dada6988fc40bca17df801e888c78585111db4e8366a2f26218dc6a161d822b4e58d38be3495e2b3f96e0a3e90544e0419080d9848aa33d9aff SHA512 93b46c6a9b582c7e2d571bbb56f48c67a173a448d59346161a0b7f11cd3c9f51ab4ec4e7dbc56860e1130454a29538e7802cc5ff9bcc5d0c1888e15ee153ac6a
51 changes: 51 additions & 0 deletions app-emacs/denote/denote-3.0.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

NEED_EMACS=28.1

inherit elisp

DESCRIPTION="Simple notes for Emacs with an efficient file-naming scheme"
HOMEPAGE="https://protesilaos.com/emacs/denote/
https://github.com/protesilaos/denote/"

if [[ "${PV}" == *9999* ]] ; then
inherit git-r3

EGIT_REPO_URI="https://github.com/protesilaos/${PN}.git"
else
SRC_URI="https://github.com/protesilaos/${PN}/archive/${PV}.tar.gz
-> ${P}.tar.gz"

KEYWORDS="~amd64 ~x86"
fi

LICENSE="GPL-3+"
SLOT="0"

DOCS=( CHANGELOG.org README.md )
ELISP_TEXINFO="${PN}.texi"
SITEFILE="50${PN}-gentoo.el"

elisp-enable-tests ert tests

src_prepare() {
default

# Skip failing test. Tests are marked as "WORK IN PROGRESS" at the
# top of the file.
local skip_tests=(
denote-test--denote-get-identifier
)
for test in "${skip_tests[@]}"; do
sed -i "/${test}/a (ert-skip nil)" tests/denote-test.el || die
done
}

src_compile() {
elisp-org-export-to texinfo README.org
elisp_src_compile
elisp-make-autoload-file
}

0 comments on commit 132aa54

Please sign in to comment.