Skip to content

Commit

Permalink
media-libs/gstreamer: correctly fix bug #577312
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
blueness committed May 11, 2016
1 parent a5b3ac3 commit 13861e7
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
32 changes: 32 additions & 0 deletions media-libs/gstreamer/files/gstreamer-1.6.3-fix-strsignal.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
Upstream split this one commit into two: c9da8b0 and d6e25dd because
of some confusion. I've recombined it here. See:

https://bugzilla.gnome.org/show_bug.cgi?id=763567
https://bugs.gentoo.org/show_bug.cgi?id=577312

diff --git a/libs/gst/check/libcheck/strsignal.c b/libs/gst/check/libcheck/strsignal.c
index b79409b..57e71cd 100644
--- a/libs/gst/check/libcheck/strsignal.c
+++ b/libs/gst/check/libcheck/strsignal.c
@@ -1,6 +1,6 @@
#include "libcompat.h"

-const char *
+char *
strsignal (int sig)
{
static char signame[40];

diff --git a/libs/gst/check/libcheck/libcompat.h b/libs/gst/check/libcheck/libcompat.h
index 32f944c..f09289b 100644
--- a/libs/gst/check/libcheck/libcompat.h
+++ b/libs/gst/check/libcheck/libcompat.h
@@ -101,7 +101,7 @@ CK_DLL_EXP char *strdup (const char *str);
#endif /* !HAVE_DECL_STRDUP && HAVE__STRDUP */

#if !HAVE_DECL_STRSIGNAL
-CK_DLL_EXP const char *strsignal (int sig);
+CK_DLL_EXP char *strsignal (int sig);
#endif /* !HAVE_DECL_STRSIGNAL */

/*
4 changes: 4 additions & 0 deletions media-libs/gstreamer/gstreamer-1.6.3.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -30,6 +30,10 @@ DEPEND="${RDEPEND}
"
# gtk-doc-am to install API docs

src_prepare() {
epatch "${FILESDIR}"/${P}-fix-strsignal.patch #577312
}

src_configure() {
if [[ ${CHOST} == *-interix* ]] ; then
export ac_cv_lib_dl_dladdr=no
Expand Down

0 comments on commit 13861e7

Please sign in to comment.