Skip to content

Commit

Permalink
dev-php/recaptcha: new version 1.2.1.
Browse files Browse the repository at this point in the history
Signed-off-by: Michael Orlitzky <[email protected]>
Package-Manager: Portage-2.3.49, Repoman-2.3.10
  • Loading branch information
orlitzky committed Oct 12, 2018
1 parent 317b0e7 commit 138e62b
Show file tree
Hide file tree
Showing 2 changed files with 35 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/recaptcha/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST recaptcha-1.1.3.tar.gz 12909 BLAKE2B cbffb64148f3359f4d351089fde65d2b9c8136e0814b5f6aedb3cd9b7f7d3f8f77d9673059f3909b381cf9151ca34a31bb961fe8686bdda4612c718828e46036 SHA512 54e22654d3b24400e448260f1d075ba2586d33cf44e0a5187b5c1288705b29bf9de394f8ca48f7717a2480cb1ae21348cc63e724f1eb93f268407a942b13f9dd
DIST recaptcha-1.2.1.tar.gz 19935 BLAKE2B 43077b25d484940951bf070fa440b5d13c6992c2a157e06b81961b9692683a277d9507e44102dd0ba0cde66c892fd4736ed34cae4b001bdce0d4ab619828b432 SHA512 62df22a6f4b05006a6051db689994e455ada43f76406dd62c5c13f1d90ae64401e9d75c6a92f2c620a14c070d2b49199c20e70eb6284e42e676d37412a98abe4
34 changes: 34 additions & 0 deletions dev-php/recaptcha/recaptcha-1.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="PHP client library for Google's reCAPTCHA service"
HOMEPAGE="https://github.com/google/recaptcha"
SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples test"

RDEPEND="dev-lang/php"
BDEPEND="test? ( ${RDEPEND} dev-php/phpunit )"

src_install(){
insinto "/usr/share/php/${PN}"
doins -r src/autoload.php src/ReCaptcha
dodoc CONTRIBUTING.md README.md
use examples && dodoc -r examples
}

src_test(){
phpunit || die "test suite failed"
}

pkg_postinst(){
elog "${PN} has been installed in /usr/share/php/${PN}/."
elog "To use it in a script, require('${PN}/autoload.php'),"
elog "and then use the ${PN} class normally. Most of the examples in"
elog "the documentation should work without further modification."
}

0 comments on commit 138e62b

Please sign in to comment.