Skip to content

Commit

Permalink
dev-libs/gmime: version bump 3.0.3 → 3.0.5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
EvaSDK committed Dec 19, 2017
1 parent 12c0e2b commit 139f1bc
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/gmime/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST gmime-2.6.23.tar.xz 5216588 BLAKE2B e173a7dbd418663ebbc55b856359bf9286c3791827f9b7f89da48dd7c3609e77312546f9489c08d34a7dcaeb78659789809d5fafc1323cbae9b9f1c4a316c659 SHA512 2ff6718b7a555cd5b34848399f29c7d0aa5a15e1f3cb46e9258c499e874191ee00f41b737386805d3000bad34367d174a25c45d38ba90cba7902400e733afa14
DIST gmime-3.0.2.tar.xz 751944 BLAKE2B e5d8843e209ca589cb1dddb96093fde8727617b8cb6e2012ae047d343c485ee2398398e20be365090af9d7b4afcfe248897ee21181fc79bff376861ac1b4428a SHA512 246f489c168ce7e04fab664b7e9ae7772ae52f0063fb0eac9153460d84fa5d9712457d81fbd1bdcdadb7e03007cf71ed3bad5287f1639214f54167427c9209ca
DIST gmime-3.0.3.tar.xz 761844 BLAKE2B 5e4a3d0cfc9768b714dc7ee1b80e06d3c2cc0a71269339d43fc9edd341d4b6b269ece347864dc2ffc9e647503e82163bfdd8701036a1db45d278ab169cdc2edd SHA512 7a4c3026a73f4eb5c9b7717fa6dc0010191dd1ce5296792f5fb58c813a843db7377e70c7d36b59461927424f15df2b9ab58cea425b6ce64ca56f75fe8bbfca5d
DIST gmime-3.0.5.tar.xz 764188 BLAKE2B 71daa5703c7a3e0e209a35908ef9fee40d494a5d2a3819d273408a36caee18dee6852a852a9d8757e2bf9d0b958235acb69cfa7538a8f670deb00c220f77a737 SHA512 658b9008ffdf8055ffa9dfe8a5a6036a487309b0419572a9376397f68a8fc17d36ba6a05d2dfcb2ad23e634dc9e2aedd2479df1bfa0b7f8944d4c294650cb6c8
68 changes: 68 additions & 0 deletions dev-libs/gmime/gmime-3.0.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
VALA_USE_DEPEND="vapigen"

inherit flag-o-matic gnome2 vala

DESCRIPTION="Utilities for creating and parsing messages using MIME"
HOMEPAGE="http://spruce.sourceforge.net/gmime/ https://developer.gnome.org/gmime/stable/"

SLOT="3.0"
LICENSE="LGPL-2.1"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE="crypt doc idn static-libs test vala"

RDEPEND="
>=dev-libs/glib-2.32.0:2
sys-libs/zlib
crypt? ( >=app-crypt/gpgme-1.8.0:1= )
idn? ( net-dns/libidn )
vala? (
$(vala_depend)
>=dev-libs/gobject-introspection-1.30.0:= )
"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.8
virtual/libiconv
virtual/pkgconfig
doc? ( app-text/docbook-sgml-utils )
test? ( app-crypt/gnupg )
"
# gnupg is needed for tests if --enable-cryptography is enabled, which we do unconditionally

src_prepare() {
gnome2_src_prepare
use vala && vala_src_prepare
}

src_configure() {
if [[ ${CHOST} == *-solaris* ]]; then
# bug #???, why not use --with-libiconv
append-libs iconv
fi

gnome2_src_configure \
$(use_enable crypt crypto) \
$(use_enable static-libs static) \
$(use_enable vala) \
$(use_with idn libidn) \
$(usex doc "" DB2HTML=)
}

src_compile() {
gnome2_src_compile
if use doc; then
emake -C docs/tutorial html
fi
}

src_install() {
gnome2_src_install

if use doc ; then
docinto tutorial
dodoc -r docs/tutorial/html/
fi
}

0 comments on commit 139f1bc

Please sign in to comment.