Skip to content

Commit

Permalink
net-print/cups-filters: Bump to version 1.20.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.21, Repoman-2.3.6
  • Loading branch information
Lars Wendler committed Jan 30, 2018
1 parent 522a24e commit 13acdec
Show file tree
Hide file tree
Showing 2 changed files with 138 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-print/cups-filters/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST cups-filters-1.16.4.tar.xz 1440964 BLAKE2B d25525fe9db6e42b244f15550ddb3e9f
DIST cups-filters-1.17.9.tar.xz 1454068 BLAKE2B 7c4b1c1a017cbaaf5d413071195ce53e3088874e55fd98264018f033f0948449b70623adc2c6e136a7441cf4cbef4470811694379bc798aeff81fe3ed80e66ca SHA512 811d2671c660a2129c207d5d8daaa576b027ba14ac4cf4753d0e8c1190866a684e284f1e7439b864aaab332e429befbc13c567bf6c9fc1a502fe2cd7d11e5ed4
DIST cups-filters-1.18.0.tar.xz 1457748 BLAKE2B 6db45707d3c0bdd369407023423a02f8909936daeccdecf1be6007d782888352c15c5590f845e074ca8da271ce1d7262c8b98a0ec8df6e383622654c06730d29 SHA512 260f4d4c635b4ca0222a9a90a6675d7ecb1cf8b4f4428431c263f50f9152537331d2c7d77c4fa0f899a12beecd6500f6ca146f4e2d087cc6525919aa0b922647
DIST cups-filters-1.19.0.tar.xz 1465524 BLAKE2B 044ab5906f73a9405de55df953c76f7efd09ac4f7800df538c8c3cfd1651de6ed4ea6e3de9378221fef69d983f070b6dcab68dfd2b822fe59aa7f804a8c27907 SHA512 4b580734f7bac78c9d48aad7d8bb9e47227134e594fba76b1c82632fd8dd3e885f3897f7efd1a4b56647b74741f452f4e36d0157591c7fd5d626001028903d30
DIST cups-filters-1.20.0.tar.xz 1465820 BLAKE2B 3ddc0ca7017776a8b69266dc7c19484626f0f6f70a44cefc9c6e1137a7c90123beb1e4d98e75906f5dfe156af01a7725ae8f1ce668f7194f07d4595f6cbba300 SHA512 b71722cc14f81cf8cbed5b8e980c9689adc2daf6cfa72e4174b6842bd89574090831f0e986b5e32a0e9fc4e29836f04e74e72c48918d7f3a8f65faa3a6c077af
137 changes: 137 additions & 0 deletions net-print/cups-filters/cups-filters-1.20.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,137 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

GENTOO_DEPEND_ON_PERL=no

inherit perl-module systemd flag-o-matic

if [[ "${PV}" == "9999" ]] ; then
inherit bzr autotools
EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
else
SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~m68k-mint"
fi
DESCRIPTION="Cups filters"
HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"

LICENSE="MIT GPL-2"
SLOT="0"
IUSE="dbus +foomatic ipp_autosetup jpeg ldap pclm pdf perl png +postscript static-libs test tiff zeroconf"

RDEPEND="
>=app-text/poppler-0.32:=[cxx,jpeg?,lcms,tiff?,utils]
>=app-text/qpdf-3.0.2:=
dev-libs/glib:2
media-libs/fontconfig
media-libs/freetype:2
media-libs/lcms:2
>=net-print/cups-1.7.3
!<=net-print/cups-1.5.9999
sys-devel/bc
sys-libs/zlib
dbus? ( sys-apps/dbus )
foomatic? ( !net-print/foomatic-filters )
jpeg? ( virtual/jpeg:0 )
ldap? ( net-nds/openldap )
pclm? ( >=app-text/qpdf-7.0_beta1 )
pdf? ( app-text/mupdf )
perl? ( dev-lang/perl:= )
png? ( media-libs/libpng:0= )
postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
tiff? ( media-libs/tiff:0 )
zeroconf? ( net-dns/avahi[dbus] )
"
DEPEND="${RDEPEND}
dev-util/gdbus-codegen
test? ( media-fonts/dejavu )
"

src_prepare() {
default
[[ "${PV}" == "9999" ]] && eautoreconf

# Bug #626800
append-cxxflags -std=c++11
}

src_configure() {
local myeconfargs=(
--docdir="${EPREFIX}/usr/share/doc/${PF}"
--enable-imagefilters
--localstatedir="${EPREFIX}"/var
--with-browseremoteprotocols=DNSSD,CUPS
--with-cups-rundir="${EPREFIX}"/run/cups
--with-fontdir="fonts/conf.avail"
--with-pdftops=pdftops
--with-rcdir=no
--without-php
$(use_enable dbus)
$(use_enable foomatic)
$(use_enable ipp_autosetup auto-setup-driverless)
$(use_enable ldap)
$(use_enable pclm)
$(use_enable pdf mutool)
$(use_enable postscript ghostscript)
$(use_enable postscript ijs)
$(use_enable static-libs static)
$(use_enable zeroconf avahi)
$(use_with jpeg)
$(use_with png)
$(use_with tiff)
)
econf "${myeconfargs[@]}"
}

src_compile() {
default

if use perl; then
pushd "${S}/scripting/perl" > /dev/null
perl-module_src_configure
perl-module_src_compile
popd > /dev/null
fi
}

src_install() {
default

if use perl; then
pushd "${S}/scripting/perl" > /dev/null
perl-module_src_install
perl_delete_localpod
popd > /dev/null
fi

if use postscript; then
# workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
dosym gstoraster /usr/libexec/cups/filter/pstoraster
dosym gstopxl /usr/libexec/cups/filter/pstopxl
fi

find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die

cp "${FILESDIR}"/cups-browsed.init.d-r1 "${T}"/cups-browsed || die

if ! use zeroconf ; then
sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
fi

doinitd "${T}"/cups-browsed
systemd_dounit "${S}/utils/cups-browsed.service"
}

src_test() {
emake check
}

pkg_postinst() {
if ! use foomatic ; then
ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
fi
}

0 comments on commit 13acdec

Please sign in to comment.