Skip to content

Commit

Permalink
dev-ml/menhir: bump to 20181006
Browse files Browse the repository at this point in the history
Signed-off-by: Alfredo Tupone <[email protected]>
Package-Manager: Portage-2.3.66, Repoman-2.3.11
  • Loading branch information
atupone committed Jul 25, 2019
1 parent 13b3e23 commit 13d836c
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/menhir/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST menhir-20170712.tar.gz 855262 BLAKE2B 259a165f30f18720ff2fb3457a8ee51dc63202860a9ad097ad6e49e2666480019b7011a11764f2c3780cf12a246c313058a35f07d100c891e07ba3ed7cb20cca SHA512 7850fa031a2bd69e9cf17db6d8f82f716ab5f9e60b34d1a53591a3ff46750fb01880f3282a7194465441abc4c2ba60f543646097f5f0eef6fe78b36266a3dbdc
DIST menhir-20171013.tar.gz 854000 BLAKE2B d50ce48d32d3bfd588520d6e5a8af4ea628089010fb286df6f87ee3f773273427f9ac6956b4b4bc1c27592aaea1f29447f0223b6b29d9cd0533c47d10eecb318 SHA512 ba6359c471aee62c996bd6495612f444e7ac226f7aad9991a76e4daa2df00cdec2387c488c6a29246ca48079bd8199b94de09a44f1fb05465cbeddff0b39df54
DIST menhir-20181006.tar.gz 6665871 BLAKE2B 98820922c3dc9ffa27e0f9432d683aae3a1115cd5ba7d1114c57730c7dc679a918c14ef692d1287ca851c62d32aca50a034de1d4c6d4049ddf80e4694bbbae3e SHA512 a838c0b6411345ae64e21f8649367541a7e137af7e552e1dcc3da0c2212813de3d0c359dbd863d0130be897148063b406e0757fd2f18b42d43d3964963ebd4c7
36 changes: 36 additions & 0 deletions dev-ml/menhir/menhir-20181006.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit findlib eutils

DESCRIPTION="LR(1) parser generator for the OCaml language"
HOMEPAGE="http://gallium.inria.fr/~fpottier/menhir/"
SRC_URI="http://gallium.inria.fr/~fpottier/menhir/${P}.tar.gz"

LICENSE="GPL-2 LGPL-2-with-linking-exception"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
IUSE="examples +ocamlopt"

RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]"
DEPEND="${RDEPEND}
dev-ml/ocamlbuild"

src_configure() {
if ! use ocamlopt ; then
export TARGET=byte
fi
}

src_compile() {
emake PREFIX="${EPREFIX}"/usr -j1
}

src_install() {
findlib_src_preinst
emake PREFIX="${ED}"/usr docdir="${ED}"/usr/share/doc/"${PF}" $(use examples || echo "DOCS=manual.pdf") install
use examples && docompress -x /usr/share/doc/${PF}/demos
dodoc README.md CHANGES.md
}

0 comments on commit 13d836c

Please sign in to comment.