Skip to content

Commit

Permalink
dev-python/lit: Branch for 5.0.0 release
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Jul 24, 2017
1 parent e6f18f1 commit 13ea512
Showing 1 changed file with 34 additions and 0 deletions.
34 changes: 34 additions & 0 deletions dev-python/lit/lit-5.0.9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
inherit distutils-r1 git-r3

DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
https://github.com/llvm-mirror/llvm.git"
EGIT_BRANCH="release_50"

LICENSE="UoI-NCSA"
SLOT="0"
KEYWORDS=""
IUSE="test"

S=${WORKDIR}/${P}/utils/lit

# Tests require 'FileCheck' and 'not' utilities (from llvm)
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/psutil[${PYTHON_USEDEP}]
sys-devel/llvm )"

# TODO: move the manpage generation here (from sys-devel/llvm)

python_test() {
./lit.py -sv tests || die
}

0 comments on commit 13ea512

Please sign in to comment.