Skip to content

Commit

Permalink
games-board/chessx: 1.5.4 version bump
Browse files Browse the repository at this point in the history
Depending on >=dev-libs/quazip-0.9.1 is necessary as the first version
to ship an (albeit patched) working pkgconfig.

Closes: https://bugs.gentoo.org/684690
Closes: https://bugs.gentoo.org/731972
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Jul 13, 2020
1 parent 98532a8 commit 141b854
Show file tree
Hide file tree
Showing 3 changed files with 122 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-board/chessx/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST chessx-1.4.6.tgz 4223076 BLAKE2B 783ffe0a7396239066870dedcaa4b2b0c491db4f16871afe66bae7a82339916a8a574401499916fc63cf62478efb9b89c30ec85a7aa7c6d002d1119f1a6b23ef SHA512 cfa74e6423e1a2f9bca319e20645ddf8c8df6b46b64493777ca1cc93037e3f7cfc200f99a29236f7c5925448676c312abf34d395e795e7db6ef8a0832c3a523e
DIST chessx-1.5.4.tgz 3663299 BLAKE2B 3a0f222d2c122e70f66600f15a2b9a9606e56407db364a616515ebc1b7f333e260c131e61e22f59fb3cbd340555bb8c238bfd560fbc23f4c173288cd4b7e7369 SHA512 9f112b185ed8af3690cb50eafead7dfbd7896d3baebc9b10c3d32103a51cc49834703c232c159dffe24fd09601f2b41db02598c435ca56fc1031195fb9762a42
48 changes: 48 additions & 0 deletions games-board/chessx/chessx-1.5.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit desktop qmake-utils xdg

DESCRIPTION="Qt5-based Chess Database Utility"
HOMEPAGE="http://chessx.sourceforge.net/"
SRC_URI="https://sourceforge.net/projects/chessx/files/chessx/${PV}/${P}.tgz"

LICENSE="GPL-2+ LGPL-2+ LGPL-2.1+ ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="
>=dev-libs/quazip-0.9.1
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtmultimedia:5
dev-qt/qtnetwork:5
dev-qt/qtprintsupport:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
sys-libs/zlib
"
DEPEND="${RDEPEND}
dev-qt/qtconcurrent:5
"
BDEPEND="
dev-qt/linguist-tools:5
virtual/pkgconfig
"

PATCHES=( "${FILESDIR}"/${P}-system-quazip.patch )

src_configure() {
eqmake5
}

src_install() {
dobin release/${PN}
dodoc ChangeLog TODO
doicon data/images/${PN}.png
domenu unix/chessx.desktop
}
73 changes: 73 additions & 0 deletions games-board/chessx/files/chessx-1.5.4-system-quazip.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
Index: chessx.pro
===================================================================
--- a/chessx.pro
+++ b/chessx.pro
@@ -39,7 +39,6 @@ static { # Everything below takes effect
message("Static build.")
}

-DEFINES += QUAZIP_STATIC
DEFINES += QT_NO_CAST_TO_ASCII
DEFINES *= QT_USE_QSTRINGBUILDER

@@ -156,22 +155,6 @@ HEADERS += src/database/board.h \
src/gui/engineoptionlist.h \
src/gui/helpbrowser.h \
src/database/downloadmanager.h \
- src/quazip/zip.h \
- src/quazip/unzip.h \
- src/quazip/quazipnewinfo.h \
- src/quazip/quazipfileinfo.h \
- src/quazip/quazipfile.h \
- src/quazip/quazipdir.h \
- src/quazip/quazip.h \
- src/quazip/quazip_global.h \
- src/quazip/quaziodevice.h \
- src/quazip/quagzipfile.h \
- src/quazip/quacrc32.h \
- src/quazip/quachecksum32.h \
- src/quazip/quaadler32.h \
- src/quazip/JlCompress.h \
- src/quazip/ioapi.h \
- src/quazip/crypt.h \
src/gui/toolmainwindow.h \
src/gui/playerlistwidget.h \
src/gui/qled.h \
@@ -321,16 +304,6 @@ SOURCES += src/database/board.cpp \
src/gui/engineoptionlist.cpp \
src/gui/helpbrowser.cpp \
src/database/downloadmanager.cpp \
- src/quazip/quazipnewinfo.cpp \
- src/quazip/quazipfile.cpp \
- src/quazip/quazipdir.cpp \
- src/quazip/quazip.cpp \
- src/quazip/quaziodevice.cpp \
- src/quazip/quagzipfile.cpp \
- src/quazip/quacrc32.cpp \
- src/quazip/quaadler32.cpp \
- src/quazip/qioapi.cpp \
- src/quazip/JlCompress.cpp \
src/gui/toolmainwindow.cpp \
src/gui/playerlistwidget.cpp \
src/gui/qled.cpp \
@@ -401,8 +374,6 @@ SOURCES += src/database/board.cpp \
src/gui/historylabel.cpp \
src/database/streamdatabase.cpp \
src/database/refcount.cpp \
- src/quazip/unzip.cpp \
- src/quazip/zip.cpp \
src/database/arenabook.cpp \
src/gui/gamelistsortmodel.cpp \
src/gui/listwidgetex.cpp
@@ -412,8 +383,9 @@ INCLUDEPATH += src/database
INCLUDEPATH += src/guess
INCLUDEPATH += src/gui
INCLUDEPATH += src/dialogs
-INCLUDEPATH += src/quazip
-INCLUDEPATH += $$[QT_INSTALL_PREFIX]/src/3rdparty/zlib
+
+CONFIG += link_pkgconfig
+PKGCONFIG += quazip

win32 {
# DEFINES += ZLIB_WINAPI

0 comments on commit 141b854

Please sign in to comment.