Skip to content

Commit

Permalink
app-misc/screenfetch: version bump to 3.8.0
Browse files Browse the repository at this point in the history
Update -9999 to be in sync with the release version
Add curl use flag
Make the X use flag include X dependencies

Gentoo-bug: 605698
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Closes: gentoo#4176
  • Loading branch information
candrews authored and SoapGentoo committed Mar 23, 2017
1 parent e70dda0 commit 1461d35
Show file tree
Hide file tree
Showing 3 changed files with 56 additions and 13 deletions.
1 change: 1 addition & 0 deletions app-misc/screenfetch/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST screenfetch-2.7.7.zip 41420 SHA256 c50322375929c78b13afc5fd4e62259087db3988
DIST screenfetch-3.2.2.tar.gz 46668 SHA256 6f30cc06b1f19cbeffc211afdf4c754c1e77b5e35965240ea77b032bb2e32bd4 SHA512 f8ddfcebe69919c9163c2377de8dfb28f15c9dd59c43d73245591b2ba6c41123c6c8130b673d87e6068850fca3b277f93bbb626e228266ea0c87be5856e823da WHIRLPOOL 7514eafaa7fb1df51a8beb5720f771217b32b902ca4e4433cfbe0f058dc11ccd82529b7622a1686878ad2e983063cfeaed0c9302b47f335a1dc4e5cb628568e4
DIST screenfetch-3.6.5.tar.gz 54153 SHA256 b6605a94be9720a5e64778dcc43ddf23e435d6704c5d177b671aa57d34966f20 SHA512 291ec0d313deebe7931b739578b69f590ae32cb7a59c5ae6975b25240d9c5bd92b8957d6a53baf78aa95737642eadd37e081fae5b5ca5120da5a9d76bb980c59 WHIRLPOOL 33b8be75c98e09adde332792b10ff1aa808d6ed5d170aaeb9ee8eaa25925119b82a49902d39d810ae908fc65a864d5b7b6cbe9ce956054b08a8eda96e3ac4ab3
DIST screenfetch-3.7.0.tar.gz 60223 SHA256 6711fe924833919d53c1dfbbb43f3777d33e20357a1b1536c4472f6a1b3c6be0 SHA512 9a6e89ef2cd48f12b22230c7aff356ac2ece8dc7437034a51a66f8026e5ca4a630af43511a60b21e9fc9f89af9e2493b8cfa3a06294e74c3d611ae3bb0db922d WHIRLPOOL 3db52291ceef4403742f06644e1a6fc1a36a95aec9f1c3cc730676d8b731eedb9fe4efc6fd81b6701d3e26039c6783bea684cea8c14ed73bf218c04d90db4ff0
DIST screenfetch-3.8.0.tar.gz 71970 SHA256 248283ee3c24b0dbffb79ed685bdd518554073090c1c167d07ad2a729db26633 SHA512 903f42e3bfcd719c4d6b91d10e5678063e223c2baa58214c7e8dae9ea925852f9e2c07ad90148e02d87ce5f9af7b989e80e93c2f569cd579e6f4f7d5c49c62f2 WHIRLPOOL 9b413d124ac0e80bd081d88703693ba2a862e0eaed8d7f175b1935ec89425acf246021c54c05b370e1c89a4e942b4d9d598d1583321a39f6eb2323af2283305f
35 changes: 35 additions & 0 deletions app-misc/screenfetch/screenfetch-3.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

MY_PN="${PN/f/F}"

DESCRIPTION="Bash Screenshot Information Tool"
HOMEPAGE="https://github.com/KittyKatt/screenFetch"

LICENSE="GPL-3"
SLOT="0"
IUSE="curl X"

DEPEND=""
RDEPEND="
curl? ( net-misc/curl )
X? (
media-gfx/scrot
x11-apps/xdpyinfo
)"

if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="git://github.com/KittyKatt/screenFetch.git"
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/KittyKatt/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${MY_PN}-${PV}"
fi

src_install() {
newbin ${PN}-dev ${PN}
einstalldocs
}
33 changes: 20 additions & 13 deletions app-misc/screenfetch/screenfetch-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,28 +1,35 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils git-r3

MY_PN="${PN/f/F}"

DESCRIPTION="Bash Screenshot Information Tool"
HOMEPAGE="https://github.com/KittyKatt/screenFetch"
EGIT_REPO_URI="https://github.com/KittyKatt/screenFetch"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
IUSE="X"
IUSE="curl X"

DEPEND=""
RDEPEND="
curl? ( net-misc/curl )
X? (
media-gfx/scrot
x11-apps/xdpyinfo
)"

if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="git://github.com/KittyKatt/screenFetch.git"
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/KittyKatt/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${MY_PN}-${PV}"
fi

src_install() {
newbin ${PN}-dev ${PN}
dodoc CHANGELOG README.mkdn TODO
}

pkg_postinst() {
optfeature "resoluton detection" x11-apps/xdpyinfo
optfeature "screenshot taking" media-gfx/scrot
optfeature "screenshot uploading" net-misc/curl
einstalldocs
}

0 comments on commit 1461d35

Please sign in to comment.