Skip to content

Commit

Permalink
dev-lang/jsonnet-0.16.0: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Patrick McLean <[email protected]>
  • Loading branch information
chutz committed May 28, 2020
1 parent 4242682 commit 14b551f
Show file tree
Hide file tree
Showing 2 changed files with 71 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/jsonnet/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST jsonnet-0.15.0.tar.gz 21826038 BLAKE2B 722a844c00ec31b662d932a4481a71197adad680181c6a56a49dfa3e9b63696d29320c5278024d44c0ab3d7d80569514792f815ac7fa3a3cc08c7756fb6f08ad SHA512 b63c1bf82e4fc9ba3f1009ed4e4ba1010e3e7f81bd816a234e48d35607eae3cba95cab57813d35daa9f024e316bae5256340a6f8d6d884f9136cdbf062a2b351
DIST jsonnet-0.16.0.tar.gz 21828911 BLAKE2B d6e9648e259b94513507ba5a6e305f705541904d7755dc5521b7fc2940b761f413bfaba39521af54eb428337be2e75f07d12038edcf7e8a5ba95feccc8dd4a02 SHA512 80e0403ec8008cbacff8d9e8fe0e2b5d3bfa306d92c2c11d472e5721015ce4c11be745df10d25715f22f8d8594df69fabf2fe617bdded462ffc5b21f8923606f
70 changes: 70 additions & 0 deletions dev-lang/jsonnet/jsonnet-0.16.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python3_{6,7,8} )

inherit toolchain-funcs flag-o-matic distutils-r1

DESCRIPTION="A data templating language for app and tool developers "
HOMEPAGE="https://jsonnet.org/"
SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
IUSE="custom-optimization python"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND="
python? ( ${PYTHON_DEPS} )
"
RDEPEND="
python? ( ${PYTHON_DEPS} )
"
BDEPEND="
python? (
${PYTHON_DEPS}
dev-python/setuptools[${PYTHON_USEDEP}]
)
"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

PATCHES=(
"${FILESDIR}/jsonnet-0.14.0-makefile.patch"
"${FILESDIR}/jsonnet-0.12.1-dont-call-make-from-setuppy.patch"
)

distutils_enable_tests setup.py

src_prepare() {
default
use python && distutils-r1_src_prepare
}

src_configure() {
use custom-optimization || replace-flags '-O*' -O3
default
}

src_compile() {
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
jsonnet \
libjsonnet.so \
libjsonnet++.so

use python && distutils-r1_src_compile
}

src_test() {
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" test
use python && distutils-r1_src_test
}

src_install() {
dolib.so libjsonnet*.so
dobin jsonnet

use python && distutils-r1_src_install
}

0 comments on commit 14b551f

Please sign in to comment.