Skip to content

Commit

Permalink
app-admin/ansible-core: add 2.14.10
Browse files Browse the repository at this point in the history
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
prometheanfire committed Sep 13, 2023
1 parent 09be566 commit 14b74d0
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/ansible-core/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST ansible-core-2.14.10.tar.gz 3141532 BLAKE2B e96e2dd82aacb7752afb51704f3316deb3006f6da328e67a4c0789681b351d70e0a1f84325df89342c4cf8fccb07c5a28967506fcbb167319a6b65944eaa0008 SHA512 f455d35a348dcd770bcb65fac12727e8f76c373b9ef7bcf1f9802a50f7fd8e5ed67ba696d9f481458715efe9b7164d57b480be84e8463c20d155b67fe477b4be
DIST ansible-core-2.14.5.tar.gz 11620295 BLAKE2B d006f773e1c2b28582143a4f08f699e5744fba492130388fa5463053cdf8f0cc7056296daa213c72884ea0c0ba454a3e04ef118c184faba8c8d3c281ae65345a SHA512 130a0de925c7229dee350ddbf4382d87802d86aab4817ed595105db8ed5071153847dac0478f20a994670e59e53a07b77d0bf35855d309ebc222fbb61233b7db
DIST ansible-core-2.14.7.tar.gz 11455164 BLAKE2B e636d14c33ba5bb744c977ced8551962fd41ab3fc5764907597428b4b4b99102dc2ab8794a09209bd2fa9ddae8815292d99e73ced802fdf32dec792cd01b5db6 SHA512 eb0223a40a2ec6b65a34e54dac77b5aa7b8efca8330c37dafa256bffbcc38862713f939edf85367cdbf14cddda36e96eef6931bf8b98de44f5739924cde8a15c
DIST ansible-core-2.14.8.tar.gz 11456832 BLAKE2B 28f7f8e5ac7dd3fa82237fe341222867a2c57146de53cd1ef2017b1bb548d8b94801087a5d21df1ab6105cc1e20bf8ca0667722294586d3328fa7ca4b74477f5 SHA512 601c9f58db7382944bf3c597fe93c630d8aec0e77bccab992c2bfc612824185d49e0af01b1bca43ced78918d843cd9b53cb2ebd2a6e26c07747bd13ba276be2c
Expand Down
58 changes: 58 additions & 0 deletions app-admin/ansible-core/ansible-core-2.14.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{10..11} )
DISTUTILS_USE_SETUPTOOLS=bdepend
PYPI_NO_NORMALIZE=1

inherit distutils-r1

DESCRIPTION="Model-driven deployment, config management, and command execution framework"
HOMEPAGE="https://www.ansible.com/"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ansible/ansible.git"
EGIT_BRANCH="devel"
else
inherit pypi
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
fi

LICENSE="GPL-3"
SLOT="0"
RESTRICT="test"

PATCHES=(
"${FILESDIR}/resolvelib.patch"
)

RDEPEND="
dev-python/paramiko[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/cryptography[${PYTHON_USEDEP}]
dev-python/httplib2[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/netaddr[${PYTHON_USEDEP}]
dev-python/pexpect[${PYTHON_USEDEP}]
>=dev-python/resolvelib-0.5.3[${PYTHON_USEDEP}]
<dev-python/resolvelib-1.1.0[${PYTHON_USEDEP}]
net-misc/sshpass
virtual/ssh
"
BDEPEND="
>=dev-python/packaging-16.6[${PYTHON_USEDEP}]
test? (
dev-python/botocore[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
)"

distutils_enable_tests pytest

python_compile() {
export ANSIBLE_SKIP_CONFLICT_CHECK=1
distutils-r1_python_compile
}

0 comments on commit 14b74d0

Please sign in to comment.