Skip to content

Commit

Permalink
dev-libs/appstream: revision bump fixing two issues
Browse files Browse the repository at this point in the history
* Fixes a build failure LINGUAS=""
* Adds a missing dependency

Gentoo-bug: 606624
Gentoo-bug: 609358

Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
Michael Palimaka committed Feb 18, 2017
1 parent 6479a33 commit 14b8293
Showing 1 changed file with 72 additions and 0 deletions.
72 changes: 72 additions & 0 deletions dev-libs/appstream/appstream-0.10.6-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit cmake-utils xdg-utils

if [[ ${PV} = 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ximion/${PN}"
else
inherit versionator
MY_PV="$(replace_all_version_separators '_')"
MY_P="APPSTREAM_${MY_PV}"
SRC_URI="https://github.com/ximion/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~x86"
S="${WORKDIR}/${PN}-${MY_P}"
fi

DESCRIPTION="Cross-distro effort for providing metadata for software in the Linux ecosystem"
HOMEPAGE="https://www.freedesktop.org/wiki/Distributions/AppStream/"

LICENSE="LGPL-2.1+ GPL-2+"
# check APPSTREAM_LIB_API_LEVEL
SLOT="0/4"
IUSE="apt doc qt5 test"

RDEPEND="
dev-libs/glib:2
dev-libs/gobject-introspection
dev-libs/libxml2:2
dev-libs/libyaml
dev-libs/snowball-stemmer
qt5? ( dev-qt/qtcore:5 )
"
DEPEND="${RDEPEND}
app-text/docbook-xml-dtd:4.5
dev-util/itstool
sys-devel/gettext
test? (
qt5? ( dev-qt/qttest:5 )
)
"

src_prepare() {
cmake-utils_src_prepare

if ! use test; then
pushd qt > /dev/null || die
cmake_comment_add_subdirectory tests
popd > /dev/null || die
fi
}

src_configure() {
xdg_environment_reset

local mycmakeargs=(
-DSTEMMING=ON
-DL18N=ON
-DVAPI=OFF
-DMAINTAINER=OFF
-DSANITIZERS=OFF
-DDOCUMENTATION=OFF
-DAPT_SUPPORT=$(usex apt)
-DINSTALL_PREBUILT_DOCS=$(usex doc)
-DQT=$(usex qt5)
)

cmake-utils_src_configure
}

0 comments on commit 14b8293

Please sign in to comment.