Skip to content

Commit

Permalink
media-gfx/graphite2: Bump to version 1.3.10
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
Lars Wendler committed May 10, 2017
1 parent 5823ccf commit 14e7f2a
Show file tree
Hide file tree
Showing 2 changed files with 120 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-gfx/graphite2/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST graphite2-1.3.10.tgz 3889647 SHA256 90fde3b2f9ea95d68ffb19278d07d9b8a7efa5ba0e413bebcea802ce05cda1ae SHA512 d6d578feaa2d9304dc9bcd3926958070b8c23b27437a9fcb801e08e62f33a5549b7a6aa9636c7f8eb80a2a2c6d5cac97d58050fb30fd102b9fd0f8c558f4252b WHIRLPOOL 8a10ae32a7f02ad9e64982ece9b4b5169355f52160f8b9f00d1a892f785bbe14c2fdde24f5e84f6b8cbd7012edaf91b639beeeba400a3f6432b2436278a5df06
DIST graphite2-1.3.8.tgz 3885841 SHA256 9f3f25b3a8495ce0782e77f69075c0dd9b7c054847b9bf9ff130bec38f4c8cc2 SHA512 df8a3a7b67b356092fe8d4f62b7cd6d45ee7fe2b614699b0f8b29dc2441e00675021fdaec24cef4629c5294b33d6b269d596bc869fae8257f8f2e935c9db3639 WHIRLPOOL 88420608db053bd4d66b852a54eeb19359910c786ef1785e303e68f0d0d5b840b4a5cdcb7e17ae6c2064563d02b03a7be43ae203184218a8ac4d9dd40c17c56f
DIST graphite2-1.3.9.tgz 3889102 SHA256 ec0185b663059553fd46e8c4a4f0dede60a02f13a7a1fefc2ce70332ea814567 SHA512 6585a2b69b8226d6e9ba9ef67d94497b24f09b7ca64357c5455c276cf6f0dd3eb7fc05f5fbc79d0bb5e62ecd44e9e19bc4f4c20f7a1d9d6eeb2f89f67af5f1ac WHIRLPOOL b0ca8ca8b79319cf8806c4e0ee4bf61b240c6537c66cd57d191d74e2001b2eeb91ab19db3bf28aaddb9ab916e3f073fefd51bba3cb96f6b2ebde5a28c0bf3ea1
119 changes: 119 additions & 0 deletions media-gfx/graphite2/graphite2-1.3.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,119 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 )

GENTOO_DEPEND_ON_PERL="no"
inherit eutils perl-module python-any-r1 cmake-multilib

DESCRIPTION="Library providing rendering capabilities for complex non-Roman writing systems"
HOMEPAGE="http://graphite.sil.org/"
SRC_URI="mirror://sourceforge/silgraphite/${PN}/${P}.tgz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
IUSE="perl test"

RDEPEND="
perl? ( dev-lang/perl:= )
"
DEPEND="${RDEPEND}
perl? (
dev-perl/Module-Build
dev-perl/Locale-Maketext-Lexicon
)
test? (
dev-libs/glib:2
media-libs/fontconfig
media-libs/silgraphite
$(python_gen_any_dep '
dev-python/fonttools[${PYTHON_USEDEP}]
')
${PYTHON_DEPS}
perl? ( virtual/perl-Test-Simple )
)
"

PATCHES=(
"${FILESDIR}/${PN}-1.3.5-includes-libs-perl.patch"
)

pkg_setup() {
use perl && perl_set_version
use test && python-any-r1_pkg_setup
}

python_check_deps() {
has_version "dev-python/fonttools[${PYTHON_USEDEP}]"
}

src_prepare() {
cmake-utils_src_prepare

# make tests optional
if ! use test; then
sed -i \
-e '/tests/d' \
CMakeLists.txt || die
fi
}

multilib_src_configure() {
local mycmakeargs=(
"-DVM_MACHINE_TYPE=direct"
# https://sourceforge.net/p/silgraphite/bugs/49/
$([[ ${CHOST} == powerpc*-apple* ]] && \
echo "-DGRAPHITE2_NSEGCACHE:BOOL=ON")
)

cmake-utils_src_configure

# fix perl linking
if multilib_is_native_abi && use perl; then
# we rely on the fact that cmake-utils_src_configure sets BUILD_DIR
sed -i \
-e "s:@BUILD_DIR@:\"${BUILD_DIR}/src\":" \
"${S}"/contrib/perl/Build.PL || die
fi
}

src_compile() {
cmake-multilib_src_compile
if use perl; then
cd contrib/perl || die
perl-module_src_configure
perl-module_src_compile
fi
}

multilib_src_test() {
if multilib_is_native_abi; then
cmake-utils_src_test
else
einfo Cannot test since python is not multilib.
fi
}

src_test() {
cmake-multilib_src_test
if use perl; then
# Perl tests fail due to missing POD coverage...
perl_rm_files "contrib/perl/t/pod.t" "contrib/perl/t/pod-coverage.t"
cd contrib/perl || die
perl-module_src_test
fi
}

src_install() {
cmake-multilib_src_install
if use perl; then
cd contrib/perl || die
perl-module_src_install
perl_delete_localpod
fi

prune_libtool_files --all
}

0 comments on commit 14e7f2a

Please sign in to comment.