Skip to content

Commit

Permalink
games-strategy/lgeneral: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
Michael Sterrett committed Jan 13, 2016
1 parent 5e8286d commit 14ffd43
Show file tree
Hide file tree
Showing 2 changed files with 100 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-strategy/lgeneral/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST lgeneral-1.3.0.tar.gz 1679182 SHA256 bd23962a8a98c1a3d3c176213c0b1845fd872ca68c141e2beff8d1a3792784ea SHA512 b958b4ee3fb6fa2b5e416cb30ddeca82cd17f0461a1afa6adc7d48d16f8e763e1610c3e05f561e442cc9460bdca64e2ac33cf616bd26f0ca8b2274c7e2b8bb41 WHIRLPOOL f00d2d0832727a1d90839bf6f1fd941a0c31e497a330dd991680146138f1dfb516e94e67a3ac8c20a1315e033313352a1d2f6a0e7f1153a7d365c2ef68581988
DIST lgeneral-1.3.1.tar.gz 1678892 SHA256 6e95a84d7772f0bd2d64edac8c2aa45c6f750ae47bfb9dc203fe53a089e5562c SHA512 4eb8fc6d1dc134792893f3f9b23833da75412fafefea66d699a27de1954d3c1338c7e5dedef842537303368387797ecea2158a477fe1d018e3af973dd5b755e5 WHIRLPOOL 9711bc8fc83a6806abc229c8de5ef669eb8335fb0aac59f5fbee9de7c3eb82865602569c83ba3246faa4be92ff5f2f8048b721bc605e299db5b76f88fe95e2d1
DIST pg-data.tar.gz 410454 SHA256 f2f74022cf8c279451911dda0a57cffab26ebf11429d61a6596310340ed23f76 SHA512 b0df30dd9a9d0652acd8702d601c489e5d3a030854ceeb173d2daa656c00633a78a3f45814da9f4157b86544dec34eda02495742242653c7cdebba5ec9951516 WHIRLPOOL 69f22f28cf4639dab0e6cf90036c26178129d7f67decf8b95ca175bb224bb3b985cf80382e06e45db06ef21d9ab9819fc1821b3d633a67bbb06ba56a8b450022
99 changes: 99 additions & 0 deletions games-strategy/lgeneral/lgeneral-1.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,99 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit eutils autotools gnome2-utils games

MY_P="${P/_/}"
MY_P="${MY_P/beta/beta-}"
DESCRIPTION="A Panzer General clone written in SDL"
HOMEPAGE="http://lgames.sourceforge.net/index.php?project=LGeneral"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
mirror://sourceforge/${PN}/pg-data.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="nls"

RDEPEND="media-libs/libsdl[sound,video]
media-libs/sdl-mixer
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
sys-devel/gettext"

S=${WORKDIR}/${MY_P}

src_prepare() {
sed -i \
-e '/desktop_DATA/d' \
-e '/icon_DATA/d' \
Makefile.am || die

cp /usr/share/gettext/config.rpath .
rm -f missing
mv configure.in configure.ac
eautoreconf

# Build a temporary lgc-pg that knows about ${WORKDIR}:
cp -pPR "${S}" "${WORKDIR}"/tmp-build || die
sed -i \
-e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}:" \
-e "s:@D@::" \
{lgc-pg,src}/misc.c || die

cd "${WORKDIR}"/tmp-build || die
sed -i \
-e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}:" \
-e "s:@D@:${D}:" \
{lgc-pg,src}/misc.c || die
}

src_configure() {
egamesconf \
$(use_enable nls)

# Build the temporary lgc-pg:
cd "${WORKDIR}"/tmp-build || die
egamesconf \
--disable-nls \
--datadir="${D}/${GAMES_DATADIR}"
}

src_compile() {
emake

# Build the temporary lgc-pg:
cd "${WORKDIR}"/tmp-build || die
emake
}

src_install() {
default
keepdir "${GAMES_DATADIR}"/${PN}/{ai_modules,music,terrain}

# Generate scenario data:
dodir "${GAMES_DATADIR}"/${PN}/gfx/{flags,units,terrain} #413901
SDL_VIDEODRIVER=dummy "${WORKDIR}"/tmp-build/lgc-pg/lgc-pg \
-s "${WORKDIR}"/pg-data \
-d "${D}/${GAMES_DATADIR}"/${PN} || die

doicon -s 48 lgeneral.png
make_desktop_entry ${PN} LGeneral
prepgamesdirs
}

pkg_preinst() {
games_pkg_preinst
gnome2_icon_savelist
}

pkg_postinst() {
games_pkg_postinst
gnome2_icon_cache_update
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit 14ffd43

Please sign in to comment.