Skip to content

Commit

Permalink
dev-ada/aws: Add dev-ada/aws-2016
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
atupone committed Apr 30, 2017
1 parent 1876b2d commit 1526c88
Show file tree
Hide file tree
Showing 4 changed files with 88 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ada/aws/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST aws-gpl-2016-src.tar.gz 15054562 SHA256 310d7a79fba1cf622f6c8d53103226422c788126198911efef09e372d559db32 SHA512 296825e4683bbf4701a42d52cb0b58ebed8d3715972d0c5f83765987d1e96ab4d6d22835c37c043f49ae106fedf5d61ef22cbe348384c2de388519637e26df0b WHIRLPOOL 48428b840149064f96a1656074cfb2f308abdc546ece87d939ab2f95f05e668caafbe9969ab99770909739fe8a4013337cd1ea8b56a7ed06291114c5d812c62f
40 changes: 40 additions & 0 deletions dev-ada/aws/aws-2016.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit multiprocessing

MY_P=${PN}-gpl-${PV}-src

DESCRIPTION="A complete Web development framework"
HOMEPAGE="http://libre.adacore.com/tools/aws/"
SRC_URI="http://mirrors.cdn.adacore.com/art/57399112c7a447658d00e1cd -> ${MY_P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

RDEPEND="dev-ada/xmlada[static]"
DEPEND="${RDEPEND}
dev-ada/gnat_util[static]
dev-ada/asis
dev-ada/gprbuild"

S="${WORKDIR}"/${MY_P}

PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )

src_configure() {
emake -j1 setup prefix=/usr
}

src_compile() {
emake PROCESSORS=$(makeopts_jobs)
}

src_install() {
emake DESTDIR="${D}" install
einstalldocs
}
36 changes: 36 additions & 0 deletions dev-ada/aws/files/aws-2016-gentoo.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
--- aws-gpl-2016-src/shared.gpr.old 2017-01-30 20:00:39.022743691 +0100
+++ aws-gpl-2016-src/shared.gpr 2017-01-30 20:01:20.524985069 +0100
@@ -130,6 +130,7 @@
package Compiler is

for Driver ("Makefile") use "";
+ for Driver ("C") use External ("CC", "gcc");

case Build is
when "Debug" =>
@@ -151,11 +151,11 @@
end case;

for Switches ("aws-attachments.adb")
- use Common_Options & Debug_Options & ("-gnatVn");
+ use Common_Options & Debug_Options & ("-gnatVn") & Adaflags;
for Switches ("aws-session.adb")
- use Common_Options & Debug_Options & ("-gnatVn");
+ use Common_Options & Debug_Options & ("-gnatVn") & Adaflags;
for Switches ("templates_parser.adb")
- use Common_Options & Debug_Options & ("-gnatVn");
+ use Common_Options & Debug_Options & ("-gnatVn") & Adaflags;
-- Disable validity check on this unit to work-around N728-028

-- ADAFLAGS and CFLAGS should come last so that command line
--- aws-gpl-2016-src/include/include.gpr.old 2017-02-17 22:09:14.361695926 +0100
+++ aws-gpl-2016-src/include/include.gpr 2017-02-17 22:11:36.497215517 +0100
@@ -54,7 +54,7 @@

when "Release" =>
for Default_Switches ("Ada") use
- ("-gnat2012", "-O2", "-gnatws", "-gnatn") & Shared.Global_Options;
+ ("-gnat2012", "-O2", "-gnatws", "-gnatn") & Shared.Adaflags & Shared.Global_Options;
end case;

case Shared.S_Target is
11 changes: 11 additions & 0 deletions dev-ada/aws/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Tupone Alfredo</name>
</maintainer>
<longdescription lang="en">
AWS is a complete framework to develop Web based applications. The main part of the framework is the embedded Web server. This small yet powerful Web server can be embedded into your application so your application will be able to talk with a standard Web browser like Microsoft Internet Explorer or Firefox for example. Around this Web server a lot of services have been developed.
</longdescription>
</pkgmetadata>

0 comments on commit 1526c88

Please sign in to comment.