forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/android-studio: bump to 2.2.3
Package-Manager: portage-2.3.0
- Loading branch information
Showing
2 changed files
with
101 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST android-studio-ide-145.3276617-linux.zip 449256851 SHA256 b4b6c82c4d60be9887ac219ebc4efd3cba2508d1a2049242cbf1be3ca55dfe0c SHA512 71310d6b9fb071fc6b9810765389a2311a62cc706cbe71b2fe466167fb2ded7ebcc2441fe49d34a2942bb79d516f6acfcba5e214e1af42c9e2bc988a28c6fb79 WHIRLPOOL 19250788e2355fe85a30731da70d89ff7bf62b95afc17dbd18a82eb1e1b80b1d7325b2f57efbd19e107e30aa46b8a164056273aebe2c82f812df4661ed0c2fbd | ||
DIST android-studio-ide-145.3360264-linux.zip 466765476 SHA256 95014a19786c076b31f0ea980eb42a163e9738356ec08a0878b7d67b6b7ec76e SHA512 446db0013b8d815ee89fa800fb5d610507fdc8b41fc3f09f2b94984ec2918e61cd9296920311f2f394c18521be53e4d7d5b44e6b6f60a617d44a451a61df4a7d WHIRLPOOL 814b227a3b22d6b69a70b7d11fd49c399dc8c45973221d07089ccf94ec07b7aa4c453ce54814d420205eeba203687083d152e81bf2f9a753af4ffb607f47b556 | ||
DIST android-studio-ide-145.3537739-linux.zip 459957542 SHA256 982377b5694a40782cd9b1190e6fb9d2046bb9cc0767b2ba7cd5aebda773d581 SHA512 2e005b2232b43e84875008e1e0bec70afff68839733bfa6e0195be23c6c76be29540321937235620c3481beb31c030086df430e73a8e16e3a10bce5e0c98753f WHIRLPOOL f30b44abaf5f7b5b69eaa5c58864a11f2fc53b1bcf1c34ba524f7bf13de5d230476d4ab564fdeb40e1e2060a9526e3268c0189db8ed1bfbff47be4f6192f606e |
100 changes: 100 additions & 0 deletions
100
dev-util/android-studio/android-studio-2.2.3.0.145.3537739.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,100 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
inherit eutils java-pkg-2 versionator | ||
|
||
RESTRICT="strip" | ||
QA_PREBUILT="opt/${PN}/bin/libbreakgen*.so | ||
opt/${PN}/bin/fsnotifier* | ||
opt/${PN}/lib/libpty/linux/x86*/libpty.so | ||
opt/${PN}/plugins/android/lib/libwebp_jni*.so" | ||
|
||
if [[ $(get_version_component_count) -eq 6 ]]; then | ||
STUDIO_V=$(get_version_component_range 1-4) | ||
BUILD_V=$(get_version_component_range 5-6) | ||
else | ||
STUDIO_V=$(get_version_component_range 1-3) | ||
BUILD_V=$(get_version_component_range 4-5) | ||
fi | ||
|
||
DESCRIPTION="A new Android development environment based on IntelliJ IDEA" | ||
HOMEPAGE="http://developer.android.com/sdk/installing/studio.html" | ||
SRC_URI="https://dl.google.com/dl/android/studio/ide-zips/${STUDIO_V}/${PN}-ide-${BUILD_V}-linux.zip" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
IUSE="selinux" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
DEPEND="app-arch/zip | ||
dev-java/commons-logging:0 | ||
dev-java/log4j:0" | ||
|
||
# dev-java/guava:18 | ||
RDEPEND=">=virtual/jdk-1.7 | ||
selinux? ( sec-policy/selinux-android ) | ||
>=app-arch/bzip2-1.0.6-r4 | ||
dev-java/commons-logging:0 | ||
dev-java/log4j:0 | ||
>=dev-libs/expat-2.1.0-r3 | ||
>=dev-libs/libffi-3.0.13-r1 | ||
>=media-libs/fontconfig-2.10.92 | ||
>=media-libs/freetype-2.5.5 | ||
>=media-libs/libpng-1.2.51 | ||
>=media-libs/mesa-10.2.8 | ||
|| ( gnome-extra/zenity kde-apps/kdialog x11-apps/xmessage x11-libs/libnotify ) | ||
|| ( >=sys-libs/ncurses-5.9-r3:5/5[tinfo] >=sys-libs/ncurses-5.9-r3:0/5[tinfo] ) | ||
>=sys-libs/zlib-1.2.8-r1 | ||
>=x11-libs/libX11-1.6.2 | ||
>=x11-libs/libXau-1.0.7-r1 | ||
>=x11-libs/libXdamage-1.1.4-r1 | ||
>=x11-libs/libXdmcp-1.1.1-r1 | ||
>=x11-libs/libXext-1.3.2 | ||
>=x11-libs/libXfixes-5.0.1 | ||
>=x11-libs/libXrender-0.9.8 | ||
>=x11-libs/libXxf86vm-1.1.3 | ||
>=x11-libs/libdrm-2.4.46 | ||
>=x11-libs/libxcb-1.9.1 | ||
>=x11-libs/libxshmfence-1.1" | ||
S=${WORKDIR}/${PN} | ||
|
||
src_prepare() { | ||
eapply_user | ||
# This is really a bundled jdk not a jre | ||
rm -R "${S}/jre" || die "Could not remove bundled jdk" | ||
|
||
# Replace bundled jars with system | ||
# has problems with newer jdom:0 not updated to jdom:2 | ||
cd "${S}/lib" | ||
local JARS="commons-logging log4j" | ||
local j | ||
for j in ${JARS}; do | ||
rm -v ${j/:*/}*.jar | ||
java-pkg_jar-from ${j} | ||
done | ||
} | ||
|
||
src_compile() { | ||
: | ||
} | ||
|
||
src_install() { | ||
local dir="/opt/${PN}" | ||
|
||
insinto "${dir}" | ||
# Replaced bundled jre with system vm/jdk | ||
# This is really a bundled jdk not a jre | ||
doins -r * | ||
|
||
rm -rf "${D}${dir}/jre" || die | ||
dosym "/etc/java-config-2/current-system-vm" "${dir}/jre" | ||
|
||
fperms 755 "${dir}/bin/studio.sh" "${dir}"/bin/fsnotifier{,64} | ||
chmod 755 "${D}${dir}"/gradle/gradle-*/bin/gradle || die | ||
|
||
newicon "bin/studio.png" "${PN}.png" | ||
make_wrapper ${PN} ${dir}/bin/studio.sh | ||
make_desktop_entry ${PN} "Android Studio" ${PN} "Development;IDE" | ||
} |