Skip to content

Commit

Permalink
dev-java/jcifs: EAPI 6 bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
monsieurp committed Mar 23, 2017
1 parent 6f9e560 commit 1569bee
Showing 1 changed file with 45 additions and 0 deletions.
45 changes: 45 additions & 0 deletions dev-java/jcifs/jcifs-1.3.17-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

JAVA_PKG_IUSE="doc examples source"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="Library that implements the CIFS/SMB networking protocol in Java"
SRC_URI="http://jcifs.samba.org/src/${P}.tgz"
HOMEPAGE="http://jcifs.samba.org/"
LICENSE="LGPL-2.1"
SLOT="1.1"

KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"

CDEPEND="java-virtuals/servlet-api:3.0"

RDEPEND="
${CDEPEND}
>=virtual/jre-1.6"

DEPEND="
${CDEPEND}
>=virtual/jdk-1.6"

JAVA_GENTOO_CLASSPATH="servlet-api-3.0"

JAVA_SRC_DIR="src"

DOCS=( README.txt )

S="${WORKDIR}/${P/-/_}"

src_prepare() {
default
java-pkg_clean
}

src_install() {
java-pkg-simple_src_install
use examples && java-pkg_doexamples examples
einstalldocs
}

0 comments on commit 1569bee

Please sign in to comment.