forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
kde-apps/dolphin-plugins-git: 20.04.3 version bump
Signed-off-by: Andreas Sturmlechner <[email protected]>
- Loading branch information
Showing
2 changed files
with
64 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST dolphin-plugins-19.12.3.tar.xz 195464 BLAKE2B b60be81fcb9932f9f645bc614ab74c2e862ef70df6958242dc67de2b9cb570cc8961c2ac593ad99db636f19bec1793316dab21b9cee9a59cf2764b67234c312a SHA512 f6d1ce129095d0ae608b2da4d91f55b93bb8fe94795c09217cc87607bb50cd8dcc5a7dac21b8655f9993da56ef90fa705520c7ac928295edb5254050af9c4a1e | ||
DIST dolphin-plugins-20.04.2.tar.xz 211048 BLAKE2B 4ebf63bd4013b0f8bdd7a7548e67d48f4d408fc3d2b76b7ac74b5aee2a792e230f87168b9ce4df4d1788feb46768255e52707c6b2906648bb769e39349943ec1 SHA512 95545db533d2491345cf12f08eb2a615ce5c0aa62550fd49149771c13da3117e670b3e4b86b374631a7b9a404c9cb2ebecfa20ab77d026e1dd94dfde340835cd | ||
DIST dolphin-plugins-20.04.3.tar.xz 213888 BLAKE2B 8ad8e98a42c5a6d12bd3c03ffcc9f5923d1651bc10a74152f5561ebf59b50aafa24fe29d0ea6a7ce147d4f8732fa72c50664b7a890a6e4fe00c64298c8aa0bd4 SHA512 cab1d81deb8204e2d95ae10dc375d5cdc98958ae3dd0a969ee9ea78326229877cd314d2f37266b2ef1ebcdd876cffade6d7e5ee296028867f9c00592c8cd6eb6 |
63 changes: 63 additions & 0 deletions
63
kde-apps/dolphin-plugins-git/dolphin-plugins-git-20.04.3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,63 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
ECM_HANDBOOK="false" | ||
KDE_ORG_NAME="dolphin-plugins" | ||
MY_PLUGIN_NAME="git" | ||
PVCUT=$(ver_cut 1-3) | ||
KFMIN=5.70.0 | ||
QTMIN=5.14.2 | ||
inherit ecm kde.org | ||
|
||
DESCRIPTION="Dolphin plugin for Git integration" | ||
HOMEPAGE="https://kde.org/applications/system/org.kde.dolphin_plugins" | ||
|
||
LICENSE="GPL-2" # TODO: CHECK | ||
SLOT="5" | ||
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
>=kde-frameworks/kcompletion-${KFMIN}:5 | ||
>=kde-frameworks/kconfig-${KFMIN}:5 | ||
>=kde-frameworks/kcoreaddons-${KFMIN}:5 | ||
>=kde-frameworks/ki18n-${KFMIN}:5 | ||
>=kde-frameworks/kio-${KFMIN}:5 | ||
>=kde-frameworks/ktextwidgets-${KFMIN}:5 | ||
>=kde-apps/dolphin-${PVCUT}:5 | ||
>=dev-qt/qtgui-${QTMIN}:5 | ||
>=dev-qt/qtwidgets-${QTMIN}:5 | ||
" | ||
RDEPEND="${DEPEND} | ||
!kde-apps/dolphin-plugins:5 | ||
dev-vcs/git | ||
" | ||
|
||
src_prepare() { | ||
ecm_src_prepare | ||
# kxmlgui, qtnetwork only required by dropbox | ||
ecm_punt_bogus_dep Qt5 Network | ||
ecm_punt_bogus_dep KF5 XmlGui | ||
# delete non-${PN} translations | ||
if [[ ${KDE_BUILD_TYPE} = release ]]; then | ||
find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die | ||
fi | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DBUILD_${MY_PLUGIN_NAME}=ON | ||
-DBUILD_bazaar=OFF | ||
-DBUILD_dropbox=OFF | ||
-DBUILD_hg=OFF | ||
-DBUILD_svn=OFF | ||
) | ||
ecm_src_configure | ||
} | ||
|
||
src_install() { | ||
ecm_src_install | ||
rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die | ||
} |