Skip to content

Commit

Permalink
app-emulation/vagrant: version bump to 1.9.8.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.8, Repoman-2.3.2
Closes: gentoo#5657
  • Loading branch information
hydrapolic authored and monsieurp committed Sep 10, 2017
1 parent ad10713 commit 15758da
Show file tree
Hide file tree
Showing 3 changed files with 89 additions and 1 deletion.
1 change: 1 addition & 0 deletions app-emulation/vagrant/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST vagrant-1.9.6.tar.gz 1115853 SHA256 08cde24b5def90e7674d333149ca9d9aec585bdb54ca41598e16ea91a56675bb SHA512 d8ed38a1fcffe31d974e94cf48b8dc4902a8005747dfe7311faa21ab53d838c88974c4c200dcbc0fb27fd50f2e3278e1fd21856e4afa37eaf4ef8602e0f5ca5d WHIRLPOOL cb8f1334f9db55be65fb5fd6dc670535681ed0b5457f15f86599fc2ca37fa791304665b913e5085d78012af7b7bd56c6281b78b70e4f054abb5d460cc14a1174
DIST vagrant-1.9.7.tar.gz 1119024 SHA256 194de72442a2d08f6e04fbed8698a99d190a0e7203d35b49e80d4ddfcb71fb1b SHA512 062921070ace7ce93145981b5b768dc9dc447559fc12c52c8da323d1e3523fbff2a8e7afca0e2f751e232aae822c969b5d166b3b0f01a0744ca20c4e4e33567f WHIRLPOOL ef0331781cf6a71dca9eb485943c459a5360f55b1db45b4f23b413b848eeac1700afe3ea51b6dd2e0da1a7c1ba6ad456bd9fcb7a7b3532145e95a38fc997dd99
DIST vagrant-1.9.8.tar.gz 1127560 SHA256 59c1d50437d2f50eeae219bc03c90d397fe8d8c974cce7c51b017b8ceeaefb54 SHA512 d22cc0a6800aa5ef84085c750f5ec8729f7b3adefd9a5df1a1fcaf60d1219e781869ede4f57ce4fdeb269224603dfc3a8024545a0250ebd9e144745ce9aa670b WHIRLPOOL d9c199322798e792a895aef03f729b4db8bb5eb3eaab960092d5aa2831032106a9f55ac3957b43378cceea2d27cf53f8ecf6ff38ff54ff2f8c4451c0238029ee
8 changes: 7 additions & 1 deletion app-emulation/vagrant/files/vagrant.in
Original file line number Diff line number Diff line change
Expand Up @@ -25,7 +25,7 @@ export VAGRANT_INSTALLER_ENV=1
# This is currently used only in Vagrant::Plugin::Manager.system_plugins_file
# to locate plugins configuration file.
export VAGRANT_INSTALLER_EMBEDDED_DIR="/var/lib/vagrant"
export VAGRANT_INSTALLER_VERSION="2"
export VAGRANT_INSTALLER_VERSION=2

# Export the OS as an environmental variable that Vagrant can access
# so that it can behave better.
Expand All @@ -34,5 +34,11 @@ export VAGRANT_DETECTED_OS="$(uname -s 2>/dev/null)"
# Export the VAGRANT_EXECUTABLE so that pre-rubygems can optimize a bit
export VAGRANT_EXECUTABLE="${VAGRANT_DIR}/bin/vagrant"

# Allow to install plugins even with deps in different slots (Bug #628648)
export VAGRANT_DISABLE_STRICT_DEPENDENCY_ENFORCEMENT=1

# Make it work with rvm (Bugs #474476 #628648)
unset GEM_HOME GEM_PATH

# Call the actual Vagrant bin with our arguments
exec ruby "${VAGRANT_EXECUTABLE}" "$@"
81 changes: 81 additions & 0 deletions app-emulation/vagrant/vagrant-1.9.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,81 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
USE_RUBY="ruby22 ruby23"

RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
RUBY_FAKEGEM_TASK_DOC=""

inherit bash-completion-r1 ruby-fakegem eutils

DESCRIPTION="A tool for building and distributing development environments"
HOMEPAGE="http://vagrantup.com/"
SRC_URI="https://github.com/mitchellh/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="+virtualbox"

RDEPEND="${RDEPEND}
app-arch/libarchive
net-misc/curl
virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"

ruby_add_rdepend "
>=dev-ruby/childprocess-0.6.0
>=dev-ruby/erubis-2.7.0
<dev-ruby/i18n-0.8.0:*
>=dev-ruby/listen-3.1.5
>=dev-ruby/hashicorp-checkpoint-0.1.1
>=dev-ruby/log4r-1.1.9 <dev-ruby/log4r-1.1.11
>=dev-ruby/net-ssh-4.1.0:*
>=dev-ruby/net-sftp-2.1
>=dev-ruby/net-scp-1.2.0
|| ( dev-ruby/rest-client:2 >=dev-ruby/rest-client-1.6.0:0 )
>=dev-ruby/nokogiri-1.7.1
<dev-ruby/mime-types-3:*
"

ruby_add_bdepend "
>=dev-ruby/rake-12.0.0
"

all_ruby_prepare() {
# remove bundler support
sed -i '/[Bb]undler/d' Rakefile || die
rm Gemfile || die

# loosen dependencies
sed -e '/hashicorp-checkpoint\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
-e '/ruby_dep/s/<=/>=/' \
-i ${PN}.gemspec || die

# remove windows-specific gems
sed -e '/wdm\|winrm/d' \
-i ${PN}.gemspec || die

# remove bsd-specific gems
sed -e '/rb-kqueue/d' \
-i ${PN}.gemspec || die

# disable embedded CA certs and use system ones
epatch "${FILESDIR}"/${PN}-1.8.1-disable-embedded-cacert.patch

sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in" > "${PN}" || die
}

all_ruby_install() {
newbashcomp contrib/bash/completion.sh ${PN}
all_fakegem_install

# provide executable similar to upstream:
# https://github.com/mitchellh/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
dobin "${PN}"

# directory for plugins.json
dodir /var/lib/vagrant
}

0 comments on commit 15758da

Please sign in to comment.