Skip to content

Commit

Permalink
dev-cpp/lucene++: EAPI-6 bump
Browse files Browse the repository at this point in the history
Signed-off-by: Andreas Sturmlechner <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Closes: gentoo#10144
  • Loading branch information
a17r committed Oct 22, 2018
1 parent 3bf1980 commit 1593c2f
Showing 1 changed file with 36 additions and 0 deletions.
36 changes: 36 additions & 0 deletions dev-cpp/lucene++/lucene++-3.0.7-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

MY_P="LucenePlusPlus-rel_${PV}"
inherit cmake-utils

DESCRIPTION="C++ port of Lucene library, a high-performance, full-featured text search engine"
HOMEPAGE="https://github.com/luceneplusplus/LucenePlusPlus"
SRC_URI="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="|| ( LGPL-3 Apache-2.0 )"
SLOT="0"
KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
IUSE="debug"

DEPEND="dev-libs/boost:="
RDEPEND="${DEPEND}"

RESTRICT="test"

S="${WORKDIR}/${MY_P}"

DOCS=( AUTHORS README.rst )

PATCHES=( "${FILESDIR}/${P}-boost-1.58.patch" )

src_configure() {
local mycmakeargs=(
-DENABLE_DEMO=OFF
-DENABLE_TEST=OFF
)

cmake-utils_src_configure
}

0 comments on commit 1593c2f

Please sign in to comment.