Skip to content

Commit

Permalink
gnome-extra/cinnamon-screensaver: 5.2.0 version bump
Browse files Browse the repository at this point in the history
Add Python 3.10 support.

Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Matthew S. Turnbull <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
SparkyBluefang authored and thesamesam committed Jan 21, 2022
1 parent 5a1e138 commit 15a8a65
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-extra/cinnamon-screensaver/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cinnamon-screensaver-5.0.7.tar.gz 154480 BLAKE2B 38b89e2d4729ea2806903e9bd27024b274248325720d233485ab756477625bc07832582bbe99c599b7a7d4dbcf76d22b59df179ac8617a81b584b9f5684cb6d2 SHA512 ec5990e1f73983e96eb07f0d4d1a66076d067df28d56c68cce987dc7fce35871650273d2d4a64058d73c7daff2326722e3c1a2fd86afc761d81d1a6b2e7f9370
DIST cinnamon-screensaver-5.2.0.tar.gz 154678 BLAKE2B 65e2ecf62319198b7637129711bc7cce08ad05a9ed89f30553bac77e5e4b147bdbcb992a1e8717e903912d0b4f70075684b40c136afc0099182c1101f1ba1a0b SHA512 d248ef848d2990a8464ff866b4d090b60531832c7a327b10f879c5a00558e14b70c6b45223550ad4100e7af1a491dc7c460c27d159c28eb289a37b916d89ad41
74 changes: 74 additions & 0 deletions gnome-extra/cinnamon-screensaver/cinnamon-screensaver-5.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7,8,9,10} )

inherit meson python-single-r1 xdg

DESCRIPTION="Screensaver for Cinnamon"
HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cinnamon-screensaver"
SRC_URI="https://github.com/linuxmint/cinnamon-screensaver/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
IUSE="systemd xinerama"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
KEYWORDS="~amd64 ~arm64 ~riscv ~x86"

COMMON_DEPEND="
${PYTHON_DEPS}
>=dev-libs/dbus-glib-0.78
>=dev-libs/glib-2.37.3:2[dbus]
>=gnome-extra/cinnamon-desktop-5.2:0=
sys-apps/dbus
sys-libs/pam
>=x11-libs/gtk+-3.22:3[introspection]
x11-libs/libX11
x11-libs/libXext
x11-libs/libXrandr
x11-themes/adwaita-icon-theme
xinerama? ( x11-libs/libXinerama )
"
RDEPEND="
${COMMON_DEPEND}
>=app-accessibility/caribou-0.3
sys-apps/accountsservice[introspection]
$(python_gen_cond_dep '
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/setproctitle[${PYTHON_USEDEP}]
>=dev-python/python3-xapp-2.2.1-r1[${PYTHON_USEDEP}]
')
systemd? ( >=sys-apps/systemd-31 )
!systemd? ( sys-auth/elogind )
"
DEPEND="
${COMMON_DEPEND}
x11-base/xorg-proto
"
BDEPEND="
dev-util/gdbus-codegen
sys-devel/gettext
virtual/pkgconfig
"

src_prepare() {
default
python_fix_shebang install-scripts src
}

src_configure() {
local emesonargs=(
$(meson_use xinerama)
)
meson_src_configure
}

src_install() {
meson_src_install
python_optimize "${ED}"/usr/share/cinnamon-screensaver/
}

0 comments on commit 15a8a65

Please sign in to comment.